Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2022, 18:41

Закрашивание ячеек ТЧ через одну

Автор Vasylii, 25 ноя 2022, 10:27

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

написал штуку для закрашивания через одну вот функция снизу, не могу понять почему закрашивается только первая таблица из 3, УТ редакция 11
                         Если Веделять тогда
Если НаборыСервер.ИспользоватьОбластьНабор(СтрокаТовары, ИспользоватьНаборы) Тогда
ОбластьКодовСтроки   = ОбластьКодовСтрокиНаборСерая;
ОбластьНомераСтроки  = ОбластьНомераСтрокиНаборСерая;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиНаборСерая;
ОбластьТоварСтроки   = ОбластьТоварСтрокиНаборСерая;
ИначеЕсли НаборыСервер.ИспользоватьОбластьКомплектующие(СтрокаТовары, ИспользоватьНаборы) Тогда
ОбластьКодовСтроки   = ОбластьКодовСтрокиКомплектующиеСерая;
ОбластьНомераСтроки  = ОбластьНомераСтрокиКомплектующиеСерая;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиКомплектующиеСерая;
ОбластьТоварСтроки   = ОбластьТоварСтрокиКомплектующиеСерая;
Иначе
ОбластьКодовСтроки   = ОбластьКодовСтрокиСтандартСерая;
ОбластьНомераСтроки  = ОбластьНомераСтрокиСтандартСерая;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиСтандартСерая;
ОбластьТоварСтроки   = ОбластьТоварСтрокиСтандартСерая;
КонецЕсли;
Иначе
Если НаборыСервер.ИспользоватьОбластьНабор(СтрокаТовары, ИспользоватьНаборы) Тогда
ОбластьКодовСтроки   = ОбластьКодовСтрокиНабор;
ОбластьНомераСтроки  = ОбластьНомераСтрокиНабор;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиНабор;
ОбластьТоварСтроки   = ОбластьТоварСтрокиНабор;
ИначеЕсли НаборыСервер.ИспользоватьОбластьКомплектующие(СтрокаТовары, ИспользоватьНаборы) Тогда
ОбластьКодовСтроки   = ОбластьКодовСтрокиКомплектующие;
ОбластьНомераСтроки  = ОбластьНомераСтрокиКомплектующие;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиКомплектующие;
ОбластьТоварСтроки   = ОбластьТоварСтрокиКомплектующие;
Иначе
ОбластьКодовСтроки   = ОбластьКодовСтрокиСтандарт;
ОбластьНомераСтроки  = ОбластьНомераСтрокиСтандарт;
ОбластьДанныхСтроки  = ОбластьДанныхСтрокиСтандарт;
ОбластьТоварСтроки   = ОбластьТоварСтрокиСтандарт;
КонецЕсли;
КонецЕсли;
Веделять = НЕ Веделять;

Vasylii

вот как это выглядит при выводе и на макете

LexaK

Vasylii, а зачем? есть механизм платформы, называется чередование строк! сама платформа красит (и без всего это г..кода)
если помогло нажмите: Спасибо!

Vasylii

LexaK, помогите адаптировать пожалуйста ибо я не много не понимаю

Vasylii

там еще вся проблема в том что итоги по выводятся желтым и как бы чередование не закрашивало их

LexaK

попробуйте в конфигураторе, в свойствах элемента ВашаТабЧасть реквизит: ЧередованиеЦветовСтрок поставить галку,
и задать цвет фона строки отличный от белого.

у меня так работает!
и ни строчки кода при этом!
если помогло нажмите: Спасибо!

Vasylii

LexaK, все равно не понял, можете скрины прислать?

LexaK

если помогло нажмите: Спасибо!

Vasylii

LexaK, так не мне такое не подходит у меня макет во внешней обработке

LexaK

ааа, да, перепутал табличный документ с табличной частью
в макете можно сделать две одинаковых строки с одиноковыми параметрами
обозвать их Строка1 и Строка2 (у одной из них, задать нужный фон), получить эти две области
и в цикле выводить поочередно, при заполнении табличного документа
если помогло нажмите: Спасибо!

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск