Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 18:12

Процент потраченного материала

Автор JeremyClarksson, 07 ноя 2022, 06:37

0 Пользователей и 1 гость просматривают эту тему.

JeremyClarksson

Всех приветствую.
Нужна помощь, нужно высчитать процент потраченного материала на продукцию.
Есть ТЧ, где перечисляется материалы, затраченные на производство. Примерно это выглядит так:

Номенклатура          КоличествоНорматив          Спецификация

Мясо                     43 кг                     Котлеты
Лук                      6 кг                      Котлеты
Мясо                     40 кг                     Пельмени
Лук                      5 кг                      Пельмени
Тесто                    12 кг                     Пельмени

Мне нужно узнать, общую сумму материалов, истраченных на продукцию и процент каждой позиции потраченного материала на продукцию
Я так понимаю, нужна какая то пропорция, вида: КоличествоНорматив / СуммаКоличестваНорматив * 100%. Тем самым получим процент по каждой позиции.
Как получить сумму каждого материала и как ее поделить на такой же материал? Чет хз. ТЧ с материалами надо свернуть?
Заранее, спасибо 

alexandr_ll

JeremyClarksson, Вы хотите определить процент по каждой позиции продукции, а таблицу выводите по всем позициям. Сделайте отдельные таблицы по каждой продукции.

JeremyClarksson

alexandr_ll, Прошу прощения, не очень понял.
Наверное, нужно написать все, что нужно сделать. Мне нужно высчитать процент потраченного материала от общей суммы на каждую спецификацию.
Пока так:
Материалы = Объект.Материалы.Выгрузить();
МатериалыСумма = Объект.Материалы.Выгрузить();
МатериалыСумма.Свернуть("Номенклатура", "Количество");
Из примера выше общее потраченное мясо 83 кг. Теперь мне нужно найти % использования мяса на каждую спецификацию. Я Материалы.Номенклатура[0] / МатериалыСумма.Номенклатура[0] * 100. Получаю процент потраченного. В итоге, хочу таблицу вида
Номенклатура  Спецификация  Процент
Мясо           Котлеты         51.8
Мясо            Пельмени        48,2
Объяснятор из меня так себе, походу

alexandr_ll

JeremyClarksson, В свернутой таблице есть общий расход продукта, Делаете цикл по развернутой таблице (со спецификациями) и для каждой строки находите процент с поиском общего расхода из свернутой таблицы.

Материалы.Колонки.Добавить("Процент",Новый ОписаниеТипов("Число"));

Для Каждого СтрМ Из МатериалыСумма Цикл
Для Каждого Стр1 Из Материалы Цикл
Если не(СТРМ.Номенклатура=Стр1.Номенклатура)) Тогда Продолжить; КонецЕсли;
            Стр1.Процент=Стр1.Количество/СтрМ.Количество*100;
        КонецЦикла;
    КонецЦикла; 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск