Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 17:56

Редактирование одной записи в регистре накопления

Автор Андрей Бутенко, 03 ноя 2022, 16:57

0 Пользователей и 1 гость просматривают эту тему.

Андрей Бутенко

Здравствуйте. Нашел в интернете код, который редактирует все записи в регистре накопления.
    //Выберем всех регистраторов регистра
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
        | УчетНоменклатуры.Регистратор
        |ИЗ
        | РегистрНакопления.УчетНоменклатуры КАК УчетНоменклатуры";
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    //Обойдем регистраторов
    Пока Выборка.Следующий() Цикл
        Сообщить("Изменение записей по регистратору: " + Выборка.Регистратор);
        //Для каждого регистратора выполним изменение набора записей
        НаборЗаписей = РегистрыНакопления.УчетНоменклатуры.СоздатьНаборЗаписей(); 
        НаборЗаписей.Отбор.Регистратор.Значение = Выборка.Регистратор;
        НаборЗаписей.Прочитать();
        Для каждого Запись Из НаборЗаписей Цикл
            Запись.Реквизит1 = "Тест";
        КонецЦикла;
        НаборЗаписей.Записать();
    КонецЦикла; 

Подскажите пожалуйста, как можно отредактировать конкретную запись в регистре?

LexaK

Андрей Бутенко, вот здесь

   Для каждого Запись Из НаборЗаписей Цикл
        //Запись.Реквизит1 = "Тест";
        Если ЭтоЗаписьКоторуюнадоОтредактировать(Запись) Тогда
           //изменяете вашу запись
           Прервать; //выходим из цикла
        КонецЕсли;
   КонецЦикла;

остальное все как у вас
если помогло нажмите: Спасибо!

Андрей Бутенко

LexaK, а   ЭтоЗаписьКоторуюнадоОтредактировать(Запись) это метод отбора? Или чтото другое

NaumovAlexey

Андрей Бутенко, это изображено твое условие отбора редактируемой записи.

LexaK

Цитата: Андрей Бутенко от 03 ноя 2022, 20:04это метод отбора? Или чтото другое
попробуйте описать словами, как вы представляете себе "нужную" запись, которую надо редактировать?
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск