Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 21:49

Как значением в табличной части изменить нужные галочки?

Автор gulnyr, 02 ноя 2022, 12:54

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Есть код:

Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
     |ИнвентаризацияОС.Ссылка КАК Ссылка,
     |ИнвентаризацияОС.Ссылка.Номер КАК Номер,
     |ИнвентаризацияОС.Ссылка.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
     |ИнвентаризацияОС.Ссылка.ОС.ОсновноеСредство,
     |ИнвентаризацияОС.ОсновноеСредство,
     |РегСведПерв.ИнвентарныйНомер КАК ИнвНомер
    |ИЗ
       |Документ.ИнвентаризацияОС.ОС КАК ИнвентаризацияОС,
         |ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПервых КАК РегСведПерв
         |ПО ИнвентаризацияОС.ОсновноеСредство = РегСведПерв.ОсновноеСредство
    |ГДЕ                                           
     |ИнвентаризацияОС.Ссылка.ПодразделениеОрганизации = &ПодразделениеОрганизации
     |И ИнвентаризацияОС.Ссылка.Номер = &НомерОрганизации
     |И ИнвентаризацияОС.Ссылка.ОС.ОсновноеСредство = РегСведПерв.ОсновноеСредство"; 

    Запрос.УстановитьПараметр(
        "ПодразделениеОрганизации",
        Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию(ВыберитеНазваниеОрганизации.ПодразделениеОрганизации)
    );                                 
   
    Запрос.УстановитьПараметр(
    "НомерОрганизации",
    ВыберитеНазваниеОрганизации.Номер
    );
   
         
      РезультатЗапроса = Запрос.Выполнить();
    ВыборкаДокументов = РезультатЗапроса.Выбрать();
   
ИнвЧисло = Новый Массив();
ИнвЧисло.Добавить(1);
ИнвЧисло.Добавить(0);
ИнвЧисло.Добавить(1);   
НумерИнв = 0;
   
    Пока ВыборкаДокументов.Следующий() Цикл
       
            Док = ВыборкаДокументов.Ссылка.ПолучитьОбъект();
           
            Для каждого Стр из Док.ОС Цикл
               
               
               
            Если Стр.ОсновноеСредство = Справочники.ОсновныеСредства.НайтиПоНаименованию(ВыборкаДокументов.ОсновноеСредство) Тогда 
               
           
                Стр.НаличиеФактическое = ИнвЧисло[НумерИнв+1];
               
                Сообщить(Стр.НаличиеФактическое);
   
            КонецЕсли;
               
           КонецЦикла;
           Док.Записать();
           
           Реквизит1 = ВыборкаДокументов.Ссылка;
           
        КонецЦикла;

Как в 1С значением в табличной части изменить нужные галочки? (в инвентаризации ОС, когда открываем нужный документ) У меня галочки проставляются для всех, а нужно проставить галочки для конкретных ОС, т.е. там, где единички (из массива ИнвЧисло).

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск