Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 дек 2022, 01:45

Редактирование Регистра накопления

Автор Андрей Бутенко, 31 окт 2022, 22:28

0 Пользователей и 1 гость просматривают эту тему.

Андрей Бутенко

Здравствуйте! Подскажите пожалуйста, как работает механизм редактирования регистров накопления.
Я нашел в интернете код, но не понимаю, как установить отбор и что туда можно записать. Процедура МодификацияЗаписейРегистраНакопления()
 
    ВыбДок = Документы.ПоступлениеТоваровУслуг.Выбрать();
    Если ВыбДок.Следующий() Тогда
        Набор = РегистрыНакопления.НДСПредъявленный.СоздатьНаборЗаписей();
        Набор.Отбор.Регистратор.Установить(!!!!Что можно написать сюда????!!!!);
        Набор.Прочитать();
 
        // Изменение существующих записей
        Для Каждого Движение Из Набор Цикл
            Движение.НДС = 0;
        КонецЦикла;
 
        // Добавление новых записей, если вдруг необходимо
        Движение = Набор.ДобавитьРасход();
        Движение.Сумма = 100;
        Движение.Период = ТекущаяДата();
 
        Движение = Набор.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Сумма = 300;
        Движение.Период = ТекущаяДата();
 
        // удаление существующих записей если надо
        Набор.Удалить(0);
 
        Набор.Записать(Истина);
    КонецЕсли;
 
КонецПроцедуры

NaumovAlexey

тут ставится ссылка на регистратор, чей набор движений вы хотите прочитать.

Но редактировать движения регистра накопления не совсем здоровая мысль. Делается это в исключительных случаях

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск