Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 21:46

Изменение записей регистра накопления

Автор Инокентий, 27 окт 2022, 17:46

0 Пользователей и 1 гость просматривают эту тему.

Инокентий

Здравствуйте, подскажите пожалуйста, как можно изменять записи в регистре накопления. Я искал в интернете инструкцию но ничего подробно понятного не нашел. Заранее спасибо

alexandr_ll

Инокентий, https://helpf.pro/faq/view/1581.html

Как изменять записи регистра накопления?

+5

Распечатать

Основной шаблон такой:

Код 1C v 8.х Набор = РегистрыНакопления.ВашРегистр.СоздатьНаборЗаписей();
Набор.Отбор.<НазваниеОтбора>.Установить(<ЗначениеОтбора>);
Набор.Прочитать();

Для Каждого ТекДвижение Из Набор Цикл

//Делаете с записями регистра то - что вам хочется

КонецЦикла;

Набор.Записать();

Реальный пример:

Код 1C v 8.х Процедура МодификацияЗаписейРегистраНакопления()

ВыбДок = Документы.ПоступлениеТоваровУслуг.Выбрать();
Если ВыбДок.Следующий() Тогда
Набор = РегистрыНакопления.НДСПредъявленный.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(ВыбДок.Ссылка);
Набор.Прочитать();

// Изменение существующих записей
Для Каждого Движение Из Набор Цикл
Движение.НДС = 0;
КонецЦикла;

// Добавление новых записей, если вдруг необходимо
Движение = Набор.ДобавитьРасход();
Движение.Сумма = 100;
Движение.Период = ТекущаяДата();

Движение = Набор.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Сумма = 300;
Движение.Период = ТекущаяДата();

// удаление существующих записей если надо
Набор.Удалить(0);

Набор.Записать(Истина);
КонецЕсли;

КонецПроцедуры


Инокентий

Цитата: alexandr_ll от 28 окт 2022, 07:52Инокентий, https://helpf.pro/faq/view/1581.html
А как работает значение отбора? Туда передается массив или какое то условие?

alexandr_ll

Инокентий, Ну вы же не все записи регистра хотите изменить, а только по отбору. Например, по одному регистратору, Одному или нескольким измерениям. То есть может быть и массив и ссылка.

Инокентий

Цитата: alexandr_ll от 28 окт 2022, 10:35Инокентий, Ну вы же не все записи регистра хотите изменить, а только по отбору. Например, по одному регистратору, Одному или нескольким измерениям. То есть может быть и массив и ссылка.
тоесть если я передам в условие массив строк из этого регистр, то получится эти строки изменить?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск