Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 дек 2022, 03:28

Как исправить "В обработчике ... используется вызов контекстного серверного метода формы"?

Автор gulnyr, 25 окт 2022, 15:52

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Код:

&НаСервере
Функция ВыбратьНомерДокументаСерв()
Запрос = Новый Запрос;
    Запрос.Текст =
"Выбрать Документ.ИнвентаризацияОС.ПодразделениеОрганизации,Документ.ИнвентаризацияОС.Номер
|Из
|Документ.ИнвентаризацияОС
|Где
|Документ.ИнвентаризацияОС.ПодразделениеОрганизации=&ПодразделениеОрганизации";

КаталогПредв = Новый Файл(ВыбратьФайлОрганизации);
ИмяФайлаКотороеНужноВывести = КаталогПредв.ИмяБезРасширения;

Запрос.УстановитьПараметр(
"ПодразделениеОрганизации",
Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию(ИмяФайлаКотороеНужноВывести)
);


ВыборкаНомераОрг = Запрос.Выполнить().Выбрать();
ВсеВыборкаНомераМассив = Новый Массив();
Пока ВыборкаНомераОрг.Следующий() Цикл
ВсеВыборкаНомераМассив.Добавить(ВыборкаНомераОрг.Номер);
КонецЦикла;

Возврат ВсеВыборкаНомераМассив;
КонецФункции

&НаКлиенте                                     
Процедура ВыбратьНомерДокументаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

Список = Новый СписокЗначений;


Для Каждого ВыбратьНомерДокументаСерв Из ВыбратьНомерДокументаСерв() Цикл
Список.Добавить(ВыбратьНомерДокументаСерв);
КонецЦикла;

ДопПараметры = Новый Структура;
ОписаниеОповещения = Новый ОписаниеОповещения("ВыбратьНомерДокумента",ЭтаФорма,ДопПараметры);
ПоказатьВыборИзСписка(ОписаниеОповещения,Список,Элемент);

КонецПроцедуры

&НаКлиенте
Процедура ВыбратьНомерДокумента(ПолученноеЗначение, ПереданныеПараметры) Экспорт
ВыбратьНомерДокумента = ПолученноеЗначение.Значение;
Сообщить(ПолученноеЗначение);
КонецПроцедуры

Выводится ошибка: В обработчике ВыбратьНомерДокументаНачалоВыбора используется вызов контекстного серверного метода формы. Но результат выводится (вместе с этой ошибкой или предупреждением).

Как исправить такую ошибку (предупреждение)?

P.S. Использовать &НаСервереБезКонтекста не вариант, т.к. не получится использовать реквизит ВыбратьФайлОрганизации.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск