Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 18:02

Условия При котором Не выводятся реквизиты с определенными условиями

Автор Vasylii, 25 окт 2022, 08:42

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

Есть Условия Если, источник финансирования есть собственные и федеральные, Если источник собственные тогда идет прогрузка ТЧ Если федерального то в тч не прогружаеться
P.S до этого было
 
Если ИсточникФинансирования = "Собственные" тогда
..........
ИсточникФинансирования = Истина;

Если Не ИсточникФинансирования = "Федерального" тогда

......

Vasylii

И не могу понять, нужно ли обязательно создавать реквизит не в ТЧ что бы передавалось значение или нет?

Vasylii

Так же Уточнение Данные ИсточникаФинансирования Берутся из Файла Excel

antoneus

Ниче не понял, но на всякий случай отвечу

Для каждого СтрокаТЧ из Объект.ТаблицаДанных Цикл
    Если СтрокаТЧ.ИсточникФинансирования = "СобственныеСредства" Тогда
        НоваяСтрока = НовыйДокумент.Товары.Добавить();
        .....заполнение строки
    КонецЕсли;
КонецЦикла;

И нет, реквизит не в ТЧ создавать необязательно

Vasylii

antoneus, Так надо Что бы выводило только собственные средства, а в таблице есть позиции где прописаны федеральные

antoneus


Vasylii

antoneus, Все я разобрался спасибо


Вот как я решил Сделать и нормально работает

Если ИсточникФинансирования <> "Собственные средства" Тогда
         Продолжить;
      КонецЕсли;   

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск