Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 дек 2022, 01:46

Как правильно создать выпадающий список, без использования модальности?

Автор gulnyr, 20 окт 2022, 10:57

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Код:

&НаКлиенте
Процедура Поле3НачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
СписокВыбора = Новый СписокЗначений;
СписокВыбора.Добавить("Самовывоз");
СписокВыбора.Добавить("Доставка");
ВыбЭлемент = ЭтаФорма.ВыбратьИзСписка(СписокВыбора, Элемент, 0);
Если НЕ ВыбЭлемент = Неопределено Тогда
СпособПолучения = ВыбЭлемент.Значение;
КонецЕсли;
СтандартнаяОбработка = Ложь;
    ОписаниеОповещения = Новый ОписаниеОповещения("ТестовыйВводСтроки", ЭтаФорма);
    ПоказатьВводСтроки(ОписаниеОповещения, СписокВыбора, "Введите строковое значение");
КонецПроцедуры

&НаКлиенте
Процедура ТестовыйВводСтроки(ПолученноеЗначение, ПереданныеПараметры) Экспорт
Сообщить("Вы ввели " + ПолученноеЗначение);
КонецПроцедуры

Есть Реквизит1 с типом: СписокЗначений

Открывается всплывающее окно с сообщением: Использование модальных окон в данном режиме запрещено!

Как это исправить? Чтобы выводился только результат выбора.

cast


antoneus

ПоказатьВыборИзСписка

У элемента формы есть свойство СписокВыбора.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск