Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 дек 2022, 03:37

Как получить значение переменной с одной процедуры на другую?

Автор gulnyr, 20 окт 2022, 07:54

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Есть примерно такой код:

&НаСервере
Процедура Первый()
ПолеА = 2;
КонецПроцедуры;

&НаКлиенте
Процедура Второй()
ПолеБ = 3;
Сообщить(ПолеА+ПолеБ);
КонецПроцедуры;

Как сделать так, чтобы можно было суммировать ПолеА и ПолеБ?

Или только через функцию такое реализуется?

Т.е. таким образом:

&НаСервере
Функция Первый()
ПолеА = 2;
Возврат ПолеА;
КонецФункции;

&НаКлиенте
Процедура Второй()
ПолеБ = 3;
Сообщить(Первый()+ПолеБ);
КонецПроцедуры;

Есть ли еще варианты?

antoneus

Есть. Передать ПолеА параметром в процедуру Первый, там вычислить и потом просуммировать в процедуре Второй().

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск