Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
08 дек 2022, 03:23

Диалог выбора файла открывается 2 раза

Автор gulnyr, 19 окт 2022, 16:01

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Код:

&НаКлиенте
Процедура ВыбратьФайлОрганизацииНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Описание = Новый ОписаниеОповещения("ВыборФайлаЗавершение", ЭтотОбъект);
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Показать(Описание);                                                                    

Диалог.Заголовок = "Выберите файл";
Если Диалог.Выбрать() Тогда
ДиалогПолноеИмяФайла = Диалог.ПолноеИмяФайла;
КаталогПредв = Новый Файл(ДиалогПолноеИмяФайла);
ДиалогПолноеИмяФайла = КаталогПредв.Имя;
Сообщить(ДиалогПолноеИмяФайла);
КонецЕсли;

КонецПроцедуры


&НаКлиенте
Процедура ВыборФайлаЗавершение(ВыбранныеФайлы, ДопПараметр) Экспорт
Если ВыбранныеФайлы = Неопределено Тогда
Возврат
КонецЕсли;
ВыбратьФайлОрганизации = ВыбранныеФайлы[0]
КонецПроцедуры

Диалог выбора файла открывается 2 раза. Как исправить?

antoneus

Оставить или Диалог.Показать или Диалог.Выбрать

gulnyr

antoneus, смысл в том, что в поле ввода хотелось бы чтобы путь к файлу отобразилась + чтобы имя файла выводилось в переменной (ДиалогПолноеИмяФайла). Можно ли как-то их объединить, при этом чтобы диалоговое окно открывалось только 1 раз?

antoneus

&НаКлиенте
Процедура ВыбратьФайлОрганизацииНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

    СтандартнаяОбработка = Ложь;               
    Описание = Новый ОписаниеОповещения("ВыборФайлаЗавершение", ЭтотОбъект);       
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Показать(Описание);                                                                                       
           
КонецПроцедуры


&НаКлиенте
Процедура ВыборФайлаЗавершение(ВыбранныеФайлы, ДопПараметр) Экспорт
    Если ВыбранныеФайлы = Неопределено Тогда
        Возврат
    КонецЕсли;
    ДиалогПолноеИмяФайла = ВыбранныеФайлы[0]
КонецПроцедуры

gulnyr

antoneus, а как имя файла вывести? Который так выводилось:
КаталогПредв = Новый Файл(ДиалогПолноеИмяФайла);
ДиалогПолноеИмяФайла = КаталогПредв.Имя;

antoneus

Так и вывести.

КаталогПредв = Новый Файл(ДиалогПолноеИмяФайла);
ИмяФайлаКотороеНужноВывести = КаталогПредв.Имя;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск