Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 23:29

1С dropbox api: как посмотреть список файлов в dropbox?

Автор gulnyr, 17 окт 2022, 08:43

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Есть такой код:

    Токен = "ЗдесьТокен";
   
    ПутьКФайлу = "Путь к файлу дропбокс";
   
    Соединение = Новый HTTPСоединение("api.dropboxapi.com",,,,,, Новый ЗащищенноеСоединениеOpenSSL);     
    Запрос = Новый HTTPЗапрос("2/files/list_folder");
    Запрос.Заголовки.Вставить("Authorization", "Bearer " + Токен);
    Запрос.Заголовки.Вставить("Content-Type", "application/octet-stream");
    ПараметрыЗаписи = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет,,, ЭкранированиеСимволовJSON.СимволыВнеASCII);
    Запись = Новый ЗаписьJSON;
    Запись.УстановитьСтроку(ПараметрыЗаписи);
    ЗаписатьJSON(Запись, Новый Структура("path", "/" + ПутьКФайлу));
    Запрос.Заголовки.Вставить("Dropbox-API-Arg", Запись.Закрыть());
   
    Ответ = Соединение.ОтправитьДляОбработки(Запрос);   
   
    Если Ответ.КодСостояния = 200 Тогда
   
        Данные = Ответ.ПолучитьТелоКакДвоичныеДанные();
   
    КонецЕсли;

Как доработать код так, чтобы можно было посмотреть список файлов в dropbox с помощью 1С?

antoneus

Соединение = Новый HTTPСоединение("api.dropboxapi.com",,,,,, Новый ЗащищенноеСоединениеOpenSSL);
Запрос = Новый HTTPЗапрос("2/files/list_folder");
Запрос.Заголовки.Вставить("Authorization", "Bearer " + Токен);
Запрос.Заголовки.Вставить("Content-Type", "application/json");
ПараметрыЗаписи = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет,,, ЭкранированиеСимволовJSON.СимволыВнеASCII);
Запись = Новый ЗаписьJSON;
Запись.УстановитьСтроку(ПараметрыЗаписи);
ЗаписатьJSON(Запись, Новый Структура("path", ""));
Запрос.УстановитьТелоИзСтроки(Запись.Закрыть());

Ответ = Соединение.ОтправитьДляОбработки(Запрос);
Если Ответ.КодСостояния = 200 Тогда
ТелоСтрокой = Ответ.ПолучитьТелоКакСтроку();
Чтение = Новый ЧтениеJSON;
Чтение.УстановитьСтроку(ТелоСтрокой);
Результат = ПрочитатьJSON(Чтение, Истина);
        Файлы = Результат["entries"];
КонецЕсли;

В переменной Файлы будет массив соответствий с папками/файлами, в отладчике уже можно разобраться что дальше делать.

gulnyr

antoneus, а список файлов как посмотреть? В документации написано про name, но не понял как его вывести.

Пробовал так:

Для Каждого ФайлыЧасть из Файлы Цикл
сообщить(ФайлыЧасть.name);
КонецЦикла;

Как правильно?

antoneus


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск