Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 19:53

По конкретному номеру инвентаризации выводятся все результаты вместо одной, как исправить?

Автор gulnyr, 07 окт 2022, 11:40

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Написал такой код:

&НаСервере
Процедура ИнвентаризацияОСВывод()

Запрос = Новый Запрос;
Запрос.Текст =
    "ВЫБРАТЬ
|ИнвентаризацияОС.Ссылка КАК Ссылка,
|ИнвентаризацияОС.Номер КАК Номер,
|ИнвентаризацияОС.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
|РегСведПерв.ИнвентарныйНомер КАК ИнвентарныйНомер
|ИЗ
|Документ.ИнвентаризацияОС КАК ИнвентаризацияОС, РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПервых КАК РегСведПерв
|ГДЕ
|ИнвентаризацияОС.ПодразделениеОрганизации = &ПодразделениеОрганизации
|И РегСведПерв.ИнвентарныйНомер = &ИнвентарныйНомер";


Запрос.УстановитьПараметр(
    "ПодразделениеОрганизации",
    Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию("ПринтерыИКО")
);

Запрос.УстановитьПараметр(
"ИнвентарныйНомер",
"1357"
);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДокументов = РезультатЗапроса.Выбрать();

Пока ВыборкаДокументов.Следующий() Цикл       
    Док = ВыборкаДокументов.Ссылка.ПолучитьОбъект();
Для каждого Стр из Док.ОС Цикл
Сообщить(Стр.ОсновноеСредство);
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Здесь мы выбираем конкретную организацию: ПринтерыИКО и конкретный инвентарный номер: 1357. В результате выводятся все результаты, которые касаются организации ПринтерыИКО.

 

Как сделать так, чтобы вывелся только позиция по инвентарному номеру: 1357?

P.S. Инвентарный номер находится здесь: РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПервых

Ивашка


gulnyr

Цитата: Ивашка от 07 окт 2022, 12:01левое соединение
Да, про это я понял, но как правильно сделать?

Если по организациям, то вроде так:
Справочник.ОсновныеСредства КАК СправочникОсновныеСредства
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних
ПО СправочникОсновныеСредства.Ссылка = ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство.Ссылка

А по номеру я не понял как сделать.

gulnyr

Ивашка, вот так сделал по левому соединению:

Запрос.Текст =
    "ВЫБРАТЬ
    |Документ.ИнвентаризацияОС.Ссылка КАК Ссылка,
    |Документ.ИнвентаризацияОС.Номер КАК Номер,
    |Документ.ИнвентаризацияОС.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    |РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ИнвентарныйНомер КАК ИнвентарныйНомер
|ИЗ
    |Документ.ИнвентаризацияОС, Справочник.ОсновныеСредства КАК СправочникОсновныеСредства
    |ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних
    |ПО СправочникОсновныеСредства.Ссылка = РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ОсновноеСредство.Ссылка
|ГДЕ
    |Документ.ИнвентаризацияОС.ПодразделениеОрганизации = &ПодразделениеОрганизации
    |И РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ИнвентарныйНомер = &ИнвентарныйНомер
|";

Все равно все выводится по указанной организации. Что здесь не то?

antoneus

Запрос.Текст =
    "ВЫБРАТЬ
    |Документ.ИнвентаризацияОС.Ссылка КАК Ссылка,
    |Документ.ИнвентаризацияОС.Номер КАК Номер,
    |Документ.ИнвентаризацияОС.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
    |РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ИнвентарныйНомер КАК ИнвентарныйНомер
|ИЗ
    |Документ.ИнвентаризацияОС
    |ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних
    |ПО Документ.ИнвентаризацияОС.ИмяРеквизитаВКоторомХранитсяОС = РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ОсновноеСредство
|ГДЕ
    |Документ.ИнвентаризацияОС.ПодразделениеОрганизации = &ПодразделениеОрганизации
    |И РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних.ИнвентарныйНомер = &ИнвентарныйНомер
|";

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск