Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 18:25

Как вывести Инвентарный номер вместе с другими реквизитами из табличной части?

Автор gulnyr, 06 окт 2022, 15:12

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Есть такой код:

&НаСервере
Процедура ИнвентаризацияОСВывод()
   
Запрос = Новый Запрос;
Запрос.Текст =
    "ВЫБРАТЬ
    |   Ссылка
    |ИЗ
    |   Документ.ИнвентаризацияОС
    |ГДЕ
    |   Номер = &Номер И ПодразделениеОрганизации = &ПодразделениеОрганизации
    |УПОРЯДОЧИТЬ ПО
    |   Дата ВОЗР";

Запрос.УстановитьПараметр(
    "Номер",
    "1156"
);

Запрос.УстановитьПараметр(
    "ПодразделениеОрганизации",
    Справочники.ПодразделенияОрганизаций.НайтиПоНаименованию("ПринтПлюс")
);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДокументов = РезультатЗапроса.Выбрать();

Пока ВыборкаДокументов.Следующий() Цикл       
    Док = ВыборкаДокументов.Ссылка.ПолучитьОбъект();
    Для каждого Стр из Док.ОС Цикл
        Сообщить(Стр.НаличиеФактическое); //Отображает
        Сообщить(Стр.ОсновноеСредство); //Отображает
        Сообщить(Стр.ИнвентарныйНомер); //Ошибка, такого объекта нет
    КонецЦикла;
КонецЦикла;   


&НаКлиенте
Процедура Команда1(Команда)

ИнвентаризацияОСВывод();   
   
КонецПроцедуры

Почему-то не получается вывести значение Стр.ИнвентарныйНомер. Как его правильно вывести?

2022-10-06_15-04-38.png

2022-10-06_15-08-22.png 

alexandr_ll


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск