Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 21:26

Как в 1С программно выбрать Инв. № с конкретным номером организации, в инвентаризации ОС

Автор gulnyr, 06 окт 2022, 08:53

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Захожу в Инвентаризация ОС, для примера нужно выбрать такую организацию с номером 0017:

2022-10-06_08-21-30.png 

Когда переходим, то получаем конкретный список инвентаризаций:

2022-10-06_08-29-12.png   

Здесь мы видим номера инвентаризации различных ОС.

Для получения Инв. № написал такой код:

&НаСервере
Процедура ИнвентарьОсновныхСредств(Номер,Подразделение)

ЗапросН = Новый запрос;
    ЗапросН.Текст =
"ВЫБРАТЬ
|    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство,
    |    ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних.ИнвентарныйНомер
    |ИЗ
    |    РегистрСведений.ПервоначальныеСведенияОСБухгалтерскийУчет.СрезПоследних КАК ПервоначальныеСведенияОСБухгалтерскийУчетСрезПоследних";


РезультатЗапросаН = ЗапросН.Выполнить();
ВыборкаДокументовН = РезультатЗапросаН.Выбрать();

Пока ВыборкаДокументовН.Следующий() Цикл

ДокН = ВыборкаДокументовН.ИнвентарныйНомер;

Сообщить(ДокН);

КонецЦикла;

КонецПроцедуры


&НаКлиенте
Процедура Команда1(Команда)

ИнвентарьОсновныхСредств("Б0312","МагазинТехники");

КонецПроцедуры

Здесь мы получаем номер инвентаризации (Б0312) без указания номера организации(0017).


Как сделать так, чтобы выбрать по номеру организации (0017) + по номеру инвентаризации (Б0312)?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск