Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 19:41

Программно создать реквизит типа Булево

Автор Samatas, 04 окт 2022, 13:00

0 Пользователей и 1 гость просматривают эту тему.

Samatas

Имеется пустой документ. Как мне программно создать и поместить на него реквизит типа булево? И как помещать этот элемент в разные элементы формы? Например в командную панель. Пробую так но реквизит на форму не появляется.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Пробую = Элементы.Добавить("Тест", Тип("ПолеФормы"));
НовЭлемент.Вид = ВидПоляФормы.ПолеФлажка;
НовЭлемент.Заголовок = "Получилось!";
НовЭлемент.Видимость = Истина;
КонецПроцедуры

Samatas

Точнее так
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
РеквизитТестовый = Новый РеквизитФормы("НазваниеРеквизита",Новый ОписаниеТипов("Булево"),
        "ПОЛУЧИЛОСЬ!!!");
НовЭлемент = Элементы.Добавить("Тест", Тип("ПолеФормы"));
НовЭлемент.Вид = ВидПоляФормы.ПолеФлажка;
НовЭлемент.Заголовок = "Получилось!";
НовЭлемент.ПутьКДанным = "НазваниеРеквизита";   //Тут не так
НовЭлемент.Видимость = Истина;
КонецПроцедуры

Samatas

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ДобавляемыеРеквизиты = Новый Массив();
РеквизитТестовый = Новый РеквизитФормы("НазваниеРеквизита",Новый ОписаниеТипов("Булево"));
ДобавляемыеРеквизиты.Добавить(РеквизитТестовый);
ЭтаФорма.ИзменитьРеквизиты(ДобавляемыеРеквизиты);
НовЭлемент = Элементы.Добавить("Тест", Тип("ПолеФормы"));
НовЭлемент.Вид = ВидПоляФормы.ПолеФлажка;
НовЭлемент.Заголовок = "Получилось!";
НовЭлемент.ПутьКДанным = "НазваниеРеквизита";   
НовЭлемент.Видимость = Истина;
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск