Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 22:53

Как в 1С по значению дополнительного сведения программно найти код основных средств?

Автор gulnyr, 27 сен 2022, 14:38

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Штрихкод в дополнительном сведении вывел примерно таким образом:

&НаСервере
Функция ВывестиШтрихкодНаСервере() 
    МассивВывестиШтрихкодНаСервере = Новый Массив();
    Запрос = Новый Запрос;
    Запрос.Текст =
    "Выбрать Первые 100
    | Значение
    | Из РегистрСведений.ДополнительныеСведения";
    ВыборкаЗначШтрих = Запрос.Выполнить().Выбрать();
    Пока ВыборкаЗначШтрих.Следующий() Цикл
        ВыборкаЗначШтрихкодов = ВыборкаЗначШтрих.Значение; //Выводим штрихкод
    КонецЦикла;
КонецФункции


А Код основного средства вывел примерно так:

Запрос = Новый Запрос;
Запрос.Текст =
"Выбрать
| Наименование,Код
| Из Справочник.ОсновныеСредства";

ВыборкаНаим = Запрос.Выполнить().Выбрать();

Пока ВыборкаНаим.Следующий() Цикл       
   ВыборкаНаименовании = ВыборкаНаим.Код; //Выводим код
КонецЦикла;

Как по значению дополнительного сведения программно найти Код основных средств?

2022-09-27_14-11-16.png

antoneus

А в регистре ДополнительныеСведения только штрихкоды содержатся? Тогда так:

&НаСервере
Функция ВывестиШтрихкодНаСервере() 
    МассивВывестиШтрихкодНаСервере = Новый Массив();
    Запрос = Новый Запрос;
    Запрос.Текст =
    "Выбрать Первые 100
    | Значение, Объект.Код КАК Код
    | Из РегистрСведений.ДополнительныеСведения";
    ВыборкаЗначШтрих = Запрос.Выполнить().Выбрать();
    Пока ВыборкаЗначШтрих.Следующий() Цикл
        ВыборкаЗначШтрихкодов = ВыборкаЗначШтрих.Значение; //Выводим штрихкод
        КодОсновногоСредства = ВыборкаЗначШтрих.Код;
    КонецЦикла;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск