Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 22:41

Не находит реквизит: Поле объекта не обнаружено (Наименование)

Автор maxxi, 27 сен 2022, 11:49

0 Пользователей и 1 гость просматривают эту тему.

maxxi

Есть такое регламентное задание, утром все норм было, выполнялась без проблем.
2 часа назад перестали данные записываться:


ЗаписьДанныхНаСервере() Экспорт
   
    ЧтениеXML=Новый ЧтениеXML;
   
    ЧтениеXML.ОткрытьФайл("\\server\proyekt\contr.xml");
   
    Результат = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML);
       
    Для каждого Элемент Из Результат.ЭлементСправочника Цикл
       
        Если ТипЗнч(Элемент.Наименование) <>Тип("Строка")  Тогда
       
                       
                НайденнаяКарта = Справочники.ДисконтКарты.НайтиПоРеквизиту("Наименование", Элемент.Наименование);
   
        Если НайденнаяКарта <> Неопределено Тогда
            Продолжить;
        КонецЕсли;
       
               НоваяКарта = Справочники.ДисконтКарты.СоздатьЭлемент();
               НоваяКарта.Наименование = Элемент.Наименование;
               НоваяКарта.Имя = Элемент.Имя;
               НоваяКарта.Фамилия = Элемент.Фамилия;
           НоваяКарта.ФИО = Элемент.ФИО;
               НоваяКарта.ПроцентКарта = Элемент.ПроцентКарта;
               НоваяКарта.СрокДействия = Элемент.СрокДействия;
           НоваяКарта.ДатаРегистрация = Элемент.ДатаРегистрация;
               НоваяКарта.Активный = Элемент.Активный;
               НоваяКарта.Адрес = Элемент.Адрес;
           НоваяКарта.ДатаРождения = Элемент.ДатаРождения;
               НоваяКарта.Активный = Элемент.Активный;
               НоваяКарта.Телефон = Элемент.Телефон;


              НоваяКарта.Записать();
       
    КонецЦикла;
 



Теперь получаю такую ошибку:

{ОбщийМодуль.ОбщийМодуль1.Модуль(17)}: Поле объекта не обнаружено (Наименование)


Если убрать эту часть все идет по плану:

     Если ТипЗнч(Элемент.Наименование) <>Тип("Строка")  Тогда
                   
     НайденнаяКарта = Справочники.ДисконтКарты.НайтиПоРеквизиту("Наименование", ЧтениеXML.Наименование);
   
         Если НайденнаяКарта <> Неопределено Тогда
           
                     Продолжить;
         
                 КонецЕсли;

LexaK

maxxi,
ЦитироватьЕсли убрать эту часть все идет по плану:
Так уберите!
если помогло нажмите: Спасибо!

antoneus

Потому что для поиска по наименованию есть специальный метод НайтиПоНаименованию.

maxxi

LexaK, не могу, код проверяет есть ли такая запись в базе или нет, если есть Продолжить

LexaK

antoneus, ей ваша подсказка не поможет!
этому пользователю надо писать полностью рабочий код, со всем ее кодом,
т.е. нужно именно - Готовое решение.
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск