Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 21:55

Поиск знаков в строке , не включая нецелочисленные и дробные числа

Автор novaOct, 26 сен 2022, 11:13

0 Пользователей и 1 гость просматривают эту тему.

novaOct

Здравствуйте. Помогите с решением задачи, подсчитывает отдельные знаки, но которые в тексте считать не собирается. Как сделать их подсчёт?

Процедура ПоискЗнака() 
 Строка = "   рив%ет d $ мирп Z rep 63556 &^*^* 94,0 л";
 ДлинаСтроки = СтрДлина(Строка);
 ТекПоз = 1;
 КолЗнаков= 0;
 РуссСим = 0;
 АнгСим = 0;
 ЭтоЗнак = Ложь;

 
 Пока ТекПоз<=ДлинаСтроки Цикл
 
  ТекСимвол = Сред(Строка,ТекПоз,1);
  Если КодСимвола(ТекСимвол)>=КодСимвола("!") И КодСимвола(ТекСимвол)<=КодСимвола("/") Тогда
   Если
      КолЗнаков=КолЗнаков+1;
  КонецЕсли;
  ТекПоз = ТекПоз+1;
 КонецЦикла;   
 Предупреждение("Кол.знаков - " + КолЗнаков); 
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск