Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 19:16

Как в 1С помощью цикла правильно вывести строки в excel?

Автор gulnyr, 25 сен 2022, 15:13

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Код цикла в 1С:

МассивК = Новый Массив();
МассивК.Добавить(111);
МассивК.Добавить(222);
МассивК.Добавить(333);

Для Каждого ЭлементМассива из МассивК Цикл //Здесь элементы 111,222,333
    Для Счетчик = 2 По МассивК.Количество()+1 Цикл //Здесь по идее по циклу подставляются номера строк         
        Лист.Cells(Счетчик, 1).Value = ЭлементМассива; //Подставляем номер строки Счетчик и значение ЭлементМассива     
    КонецЦикла; //Здесь по идее по циклу подставляются номера строк 
КонецЦикла; //Здесь элементы 111,222,333

Который по идее должен вывести в одном столбце строки:
111
222
333

Но почему-то выводится так:
333
333
333

Как сделать так, чтобы в excel записался:
111
222
333

antoneus

Лист.Cells(Счетчик, 1).Value = ЭлементМассива; //Подставляем номер строки Счетчик и значение ЭлементМассива, в первом проходе внешнего цикла по элементам в ячейки записывается 111, 111, 111, во втором проходе - 222, 222, 222, в третьем - 333, 333, 333, вывод - внешний цикл не нужен, все можно вывести в одном цикле

LexaK

gulnyr, просто нужен один проход по циклу
Для Каждого ЭлементМассива из МассивК Цикл //Здесь элементы 111,222,333
    Сообщить(ЭлементМассива );
    //Здесь добавьте выво в ексель
КонецЦикла;


если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск