Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 окт 2022, 13:26

Регламентные задания не выполняется.

Автор maxxi, 22 сен 2022, 17:11

0 Пользователей и 1 гость просматривают эту тему.

maxxi

Есть 2 общие модули,

1-Выгружает в xml из 1с в 1-ИБ.(проверяю файл, все норм. пишет)

2-загружает в 1С из файла в 2-ИБ.(обновляю Справочник, а там нет изменении)

они размещены в Регламентных заданиях

расписание настроена.

Полный доступ к папке.

В журнале регистрации пишет везде:

Фоновое задание. Успешное завершение

Помогите пожалуйста, где искать свою ошибку.

Спасибо.


LexaK

maxxi, запустите 2-рег.задание под собой под отладчиком, пройдите по командно,
возможно срабатывает какая проверка, которая завершает работу без всяких ошибок.
отладчиком умеете пользоваться?
если помогло нажмите: Спасибо!

maxxi

LexaK, Ксожалению нет, пыталась но не получается.

maxxi

Вот код:
ЧтениеXML.ОткрытьФайл("C:\data\agents.xml");
   
    Результат = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML);
       
    Для каждого Элемент Из Результат.ЭлементСправочника Цикл
       
        Если ТипЗнч(Элемент.Код) <> Тип("Строка") Тогда
            Продолжить
        КонецЕсли;
               
        НайденныйКонтрагент = Справочники.Контрагенты.НайтиПоРеквизиту("Код", Число(ЭлементКод));
   
        Если НайденныйКонтрагент <> Неопределено Тогда
            Продолжить;
        КонецЕсли;
       
        НовыйКонтрагент = Справочники.Контрагенты.СоздатьЭлемент();
        НовыйКонтрагент.Наименование = Элемент.Наименование;
        НовыйКонтрагент.Код = Элемент.Код;
        НовыйКонтрагент.ПолноеНаименование = Элемент.ПолноеНаименование;
        НовыйКонтрагент.ЮридическоеЛицо = Элемент.ЮридическоеЛиц;
        НовыйКонтрагент.Прочие = Элемент.Прочие;
        НовыйКонтрагент.Поставщик = Элемент.Поставщик;
        НовыйКонтрагент.Покупатель = Элемент.Покупатель;
        НовыйКонтрагент.Телефоны = Элемент.Телефоны;
        НовыйКонтрагент.Адрес = Элемент.Адрес;
        НовыйКонтрагент.Записать();
       
       
    КонецЦикла;

По отладке вижу: это часть кода не выполняется:

   НовыйКонтрагент = Справочники.Контрагенты.СоздатьЭлемент();
        НовыйКонтрагент.Наименование = Элемент.Наименование;
        НовыйКонтрагент.Код = Элемент.Код;
        НовыйКонтрагент.ПолноеНаименование = Элемент.ПолноеНаименование;
        НовыйКонтрагент.ЮридическоеЛицо = Элемент.ЮридическоеЛиц;
        НовыйКонтрагент.Прочие = Элемент.Прочие;
        НовыйКонтрагент.Поставщик = Элемент.Поставщик;
        НовыйКонтрагент.Покупатель = Элемент.Покупатель;
        НовыйКонтрагент.Телефоны = Элемент.Телефоны;
        НовыйКонтрагент.Адрес = Элемент.Адрес;
        НовыйКонтрагент.Записать();

maxxi

Пробовали, но не получается...(((

maxxi

Вот скрины:

antoneus

НайденныйКонтрагент не будет равно неопределено, читайте же справку, в конце концов!

Если не существует ни одного элемента с требуемым кодом, то будет возвращена пустая ссылка.
Если для справочника код не задан (длина = 0), то будет возвращено Неопределено.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск