Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 окт 2022, 12:33

Ошибка УТ, редакция 11. Реквизит недоступен для группы

Автор syemye, 19 сен 2022, 10:43

0 Пользователей и 1 гость просматривают эту тему.

syemye

Добрый день. Создаю в справочнике группу, выдает ошибку - "Реквизит недоступен для группы". - рис (ош1)

LexaK

syemye, надо или убрать этот реквизит из формы группы
или разрешить его для группы тоже
в конфигураторе, реквизит его свойство: Использование  выбрать значение = "Для группы и элемента"
если помогло нажмите: Спасибо!

syemye

LexaK, выставлено для реквизита для групп и элементов

LexaK

ошибка на какой реквизит возникает? на картинке не видно, нажмите кнопку подробно.
и база сохранена, применена, перезапущена?
если помогло нажмите: Спасибо!

syemye

LexaK, кнопки "подробно" нет. Сохранена, применена, перезапущена. Выставил на все реквизиты элемент и группы

LexaK

даа, кнопки подробно нет....
а на надпись "Сформировать отчет об ошибке" хотя бы из любопытства нажимали?
попробуйте нажмите, посмотрите отчет, выложите сюда, там точно должна быть более подробная информация.
если помогло нажмите: Спасибо!

syemye

LexaK, из любопытства нажимал - что именно формирует отчет - там информации нет.
добавил режим отладки - вот ошибка подробнее

syemye

Процедура ПередЗаписью(Отказ)
    Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    МенеджерГВК = ОбщийМодульГВК.МенеджерГВК();   
    МенеджерВеселов= ОбщийМодульГВК.МенеджерВеселов();
    ФизЛицоПользователя = Пользователи.ТекущийПользователь().ФизическоеЛицо;
    МожноРедактировать = Ложь;
    Если Пользователи.ТекущийПользователь() =  МенеджерВеселов Тогда
        МожноРедактировать = Истина;   
        ПроверкаНаГруппу = Ложь;
    ИначеЕсли Пользователи.ТекущийПользователь() =  МенеджерГВК Тогда
        МожноРедактировать = Истина;   
        ПроверкаНаГруппу = Ложь;
    ИначеЕсли ОбщийМодульГВК.ЕстьПраво("ПраваОКС") Тогда
        МожноРедактировать = Истина;   
    КонецЕсли;     
    Если МожноРедактировать Тогда 
        Наименование = СокрЛП(Наименование);
        Наименование =Врег(Лев(Наименование,1))+ Сред(Наименование,2);
        Если ЭтоГруппа Тогда
        Иначе
            Если ПустаяСтрока(НаименованиеПолное) ТОгда
                НаименованиеПолное = Наименование;   
            КонецЕсли;
           
            Если ПустаяСтрока(Этажи) и Этаж<>0 Тогда
                Этажи = СокрЛП(Этаж);
            КонецЕсли;
           
        КонецЕсли; 
        Если ЗначениеЗаполнено(ОбъектЗадания) ТОгда
           
            Отбор = Новый Структура;
            Отбор.Вставить("ОбъектЗадания",ОбъектЗадания);
            Поиск =  ОбъектыЗадания.НайтиСтроки(Отбор); 
            Если Поиск.Количество()= 0 Тогда 
                ОбъектыЗадания.Добавить().ОбъектЗадания = ОбъектЗадания;
               
            КонецЕсли;
           
        КонецЕсли;
        КоличествоОбъектовЗадания = ОбъектыЗадания.Количество();
       
    Иначе   
        ТекстСообщения = "Вам запрещено редактирование данные справочника!!!"+Символы.ПС+"Обратитесь к Веселову Сергею Владимировичу!!!";
        //ТекстСообщения = "Выберите группу номенклатуры для создания!!!"+Символы.ПС +"Номенклатура не будет эаписана!";
        //ПредупреждениеДляКлиента(Текст);
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения, ЭтотОбъект, "Наименование", , Отказ);    //"Объект.Родитель"           
        Отказ = Истина;
    КонецЕсли;   
    Если ЭтоГруппа Тогда
    Иначе 
        Если КоличествоОбъектовЗадания = 0 Тогда
                ТекстСообщения = "Не выбран Объект задания!!!";
        //ТекстСообщения = "Выберите группу номенклатуры для создания!!!"+Символы.ПС +"Номенклатура не будет эаписана!";
        //ПредупреждениеДляКлиента(Текст);
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения, ЭтотОбъект, "ОбъектЗадания", , Отказ);    //"Объект.Родитель"           
        Отказ = Истина;
         КонецЕсли;
        КонецЕсли;
КонецПроцедуры

LexaK

поставьте условие остановки по ошибке (в разделе Отладка)
(не понятно что у вас с базой, из-за чего она не показывает имя ошибочного Реквизита)
а у вас случайно Реквизита с именем "Реквизит" нет?
если помогло нажмите: Спасибо!

syemye


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск