Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 ноя 2022, 23:28

Условие "Если" во внеш печатной форме

Автор Mexxe, 01 сен 2022, 10:44

0 Пользователей и 1 гость просматривают эту тему.

Mexxe

Доброго времени ПРОФИ 1С! Будьте добры помогите разобраться новичку
Суть следующая:
Есть код
если (СсылкаНаОбъект.Контрагент.Наименование =  "ГУ ОРО ФСС РФ(Соц. страх)") и  (Стр.Номенклатура.КакВФБ = Ложь) тогда
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена) тогда   
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена;
иначе
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1;
конецесли;
иначе
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена) тогда
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена;
иначе   
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр;
КонецЕсли;

Каким образом возможно вставить еще одно условие?

если (СсылкаНаОбъект.Контрагент.Наименование =  "ГУ ОРО ФСС РФ(Соц. страх)") и  (Стр.Номенклатура.КакВФБ = Ложь) тогда
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена) тогда

///Пыталстя вот такой код вставить, но ни чего не вышло
   если стр.Номенклатура.Ремонт = Истина тогда
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена;
иначе
///Пыталстя вот такой код вставить, но ни чего не вышло
   
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена;
иначе
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1;
конецесли;
иначе
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена) тогда

///Пыталстя вот такой код вставить, но ни чего не вышло
   если стр.Номенклатура.Ремонт = Истина тогда
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена;
иначе
///Пыталстя вот такой код вставить, но ни чего не вышло

 
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена;
иначе

///Пыталстя вот такой код вставить, но ни чего не вышло
   если стр.Номенклатура.Ремонт = Истина тогда
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.ДляПечати_ДляРеестров_спр;
иначе
///Пыталстя вот такой код вставить, но ни чего не вышло
 
ОбластьЗаполнение.Параметры.Номенклатура = "" + Стр.Номенклатура.Классификатор + " " + Стр.Номенклатура.ДляПечати_ДляРеестров_спр;
КонецЕсли;

В общем как то так, в двух словах выводится номенклатура с разных мест, в зависимости от заполнение + классификатор, а нужно условие на проверку номенклатуры - если флаг стоит "Ремонт", то нужно что бы выводилась без классификатора

За ранее благодарю!








LexaK

Mexxe, вот один из вариантов

если стр.Номенклатура.Ремонт = Истина тогда
лкКлассификатор = "";// для ремонта пустой Классификатор
Иначе
лкКлассификатор = "" + Стр.Номенклатура.Классификатор + " ";
конецесли;           

если (СсылкаНаОбъект.Контрагент.Наименование =  "ГУ ОРО ФСС РФ(Соц. страх)")
и  (Стр.Номенклатура.КакВФБ = Ложь) тогда
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена) тогда   
ОбластьЗаполнение.Параметры.Номенклатура = лкКлассификатор + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1.ДлинныеИмена;
иначе
    ОбластьЗаполнение.Параметры.Номенклатура = лкКлассификатор + Стр.Номенклатура.ДляПечати_ДляРеестров_спр1;
    конецесли;           
иначе
если ЗначениеЗаполнено(Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена) тогда
    ОбластьЗаполнение.Параметры.Номенклатура = лкКлассификатор + Стр.Номенклатура.ДляПечати_ДляРеестров_спр.ДлинныеИмена;
иначе   
    ОбластьЗаполнение.Параметры.Номенклатура = лкКлассификатор + Стр.Номенклатура.ДляПечати_ДляРеестров_спр;
    КонецЕсли;
конецесли;           

если помогло нажмите: Спасибо!

Mexxe

LexaK, Благодарствую, дружище выручил, все работает
+++ в карму)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск