Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 авг 2022, 12:15

Зачем документ сам себя ищет ПередЗаписью?

Автор ajl bl, 02 авг 2022, 16:01

0 Пользователей и 1 гость просматривают эту тему.

ajl bl

Зачем перед записью документа ЧекККМ статус чека получается вот таким образом (Retail 2.2.10)?
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
...
СтатусЧекаККМПоСсылке = СтатусЧекаККМПоСсылке(Ссылка);
...
КонецПроцедуры

Функция СтатусЧекаККМПоСсылке(ДокументСсылка)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 1
| ЧекККМ.СтатусЧекаККМ
|ИЗ
| Документ.ЧекККМ КАК ЧекККМ
|ГДЕ
| ЧекККМ.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", ДокументСсылка);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Если Выборка.Следующий() Тогда
Возврат ВыБорка.СтатусЧекаККМ
Иначе
Возврат Перечисления.СтатусыЧековККМ.ПустаяСсылка()
КонецЕсли;

КонецФункции

из за етого выходит ошибка блокировки


LexaK

ajl bl, вообще нормальная/обычная ситуация, получение своих-же, ранее сохраненных данных, для какого-то контроля и/или ограничений действий,
посмотрите где дальше по коду используется эта переменная "СтатусЧекаККМПоСсылке"

приводить к блокировке не должно, скорее всего у вас неправильно настроен режим управления блокировок
(читайте настройки управления блокировками)
если помогло нажмите: Спасибо!

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск