Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 дек 2022, 17:00

Нужна подсказка по БПО

Автор Эдуард54, 30 июл 2022, 22:57

0 Пользователей и 1 гость просматривают эту тему.

Эдуард54

Коллеги, прошу помощи. В самописную конфигурацию внедрил библиотеку подключаемого оборудования. Работаю с эмулятором эквайрингового терминала.
Не могу понять где поймать исходящие параметры (КодАвторизации, СсылочныйНомер, НомерКарты, ТекстСлипЧека) при совершении оплаты по карте.

За основу взял следующие шаблоны:
&НаКлиенте
Процедура ВыполнитьОперациюПоПлатежнойКарте(Команда)

    ЭтаФорма.Доступность = Ложь; // При необходимости можно заблокировать интерфейс пользователя.
 
    ПараметрыОперации = ОборудованиеПлатежныеСистемыКлиентСервер.ПараметрыВыполненияЭквайринговойОперации();
    ПараметрыОперации.ТипТранзакции  = "AuthorizeSales";
    ПараметрыОперации.СуммаОперации  = 100;
    ПараметрыОперации.НомерЧека      = НомерЧека
    ПараметрыОперации.СсылочныйНомер = СсылочныйНомер;
      
    ОтображатьСообщения = Ложь; // Не отображать сообщения об ошибке. Сообщения на экран выводиться в процедуре обработки оповещения.

    Оповещение = Новый ОписаниеОповещения("ОперацияПоПлатежнойКартеЗавершение", ЭтотОбъект);
    ОборудованиеПлатежныеСистемыКлиент.НачатьВыполнениеОперацииНаЭквайринговомТерминале(Оповещение, УникальныйИдентификатор, ИдентификаторУстройстваЭТ, ПараметрыОперации, , ИдентификаторУстройстваПУ);

КонецПроцедуры

&НаКлиенте
Процедура ОперацияПоПлатежнойКартеЗавершение(РезультатВыполнения, Параметры) Экспорт
 
   ЭтаФорма.Доступность = Истина; // При необходимости разблокируем интерфейс пользователя.

   Если РезультатВыполнения.Результат Тогда
      ТекстСообщения = НСтр("ru = 'Операция завершена.'");
      Сообщить(ТекстСообщения);
   Иначе
      ТекстСообщения = НСтр("ru = 'При выполнении операции произошла ошибка:""%ОписаниеОшибки%"".'");
      ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ОписаниеОшибки%", РезультатВыполнения.ОписаниеОшибки);
      Сообщить(ТекстСообщения);
   КонецЕсли;

КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск