Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2022, 04:25

Расширение конфигурации

Автор HelloW, 24 июл 2022, 19:03

0 Пользователей и 1 гость просматривают эту тему.

HelloW

Добрый день.
Создал расширение конфигурации. Всё перепробывал - не получается. Теперь необходимо, чтобы у определённого пользователя при открытии формы менялась доступность некоторых полей, и у некоторых устанавливалось предопределённое значение.
В связи с этим вопросы:
1. Как изменить доступность редактирования поля "налету" в расширении?
2. Как полю присвоить предопределённое значение ссылочного типа?

Если можно - с примером.



HelloW

Разобрался, единственное остался вопрос - как при отрытии управляемой формы присвоить элемент ссылочного типа (счёт учёта)?

HelloW

Следующий код выдаёт: "Поле объекта недоступно для записи (Имя)"
Как пофиксить?






&НаСервере
функция ДайСчет()

   СчетД= ПланыСчетов.Хозрасчетный.НайтиПоКоду("70"); 
   Возврат СчетД;
   
КонецФункции



&НаКлиенте
Процедура Расш1_ПриОткрытииПосле(Отказ)
   
   Если СтрНайти(ВРег(ИмяПользователя()),"ОЛЬГА")=0 тогда //отрабатывает
      СООБЩИТЬ("Не найдено!")   
   иначе
      сообщить("Найдено!")
       Элементы.Счет.Доступность=Ложь; // этот код отрабатывает ОК

       Элементы.Счет= ДайСчет(); // ЭТОТ КОД НЕ РАБОТАЕТ!!!

   КонецЕсли;
   
   
КонецПроцедуры

LexaK

ЦитироватьЭлементы.Счет= ДайСчет(); // ЭТОТ КОД НЕ РАБОТАЕТ!!!
Элементы.Счет - это элемент формы, а нужен реквизит объекта, примерно так,
Объект.Счет = ...
посмотрите, что у вас в форме, является объектом
если помогло нажмите: Спасибо!

HelloW

Это отчёт из БП 3.0 "Карточка счёта" .
Цитата: LexaK от 24 июл 2022, 22:10посмотрите, что у вас в форме, является объектом
Если я понял правильно - "Счет"

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск