Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2022, 05:01

Работа в модуле команды

Автор Алексей_1985_06, 22 июл 2022, 21:41

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Здравствуйте форумчане! Знатоков прошу помощи, есть справочник "СписокКниг", и кнопка  "Download File" для получения электронного файла этой книги, находясь на форме списка при нажатии на данную кнопку, если файл отсутствует - то выходит окно диалога с предложением записать файл книги в РС, при нажатии "ДА", необходимо открыть форму записи РС и установить значение реквизита "НаименованиеДокумента" (измерения РС: НаименованиеДокумента) - из реквизита "НаименованиеДокумента" справочника "СписокКниг", подскажите как в модуле команды получить ссылку на элемент справочника, чтобы передать ее в параметры открытия формы записи РС

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)


Если ПолучитьАдресДокумента(ПараметрКоманды) = Неопределено  // ПолучитьАдресДокумента - процедура модуля
Тогда

Оповещение = Новый ОписаниеОповещения("ПослеОтветаНаВопрос",ЭтотОбъект);

ПоказатьВопрос(Оповещение, "Электронный документ отсутствует в базе данных библиотеки",   
РежимДиалогаВопрос.ДаНетОтмена, 0 , , "Загрузить электронный файл документа?");
Возврат
КонецЕсли;


ПараметрыДиалога = Новый ПараметрыДиалогаПолученияФайлов();
ПараметрыДиалога.Заголовок = НСтр("ru = 'Выберите путь для сохранения файла'; en = 'Select the path to save the file'");
НачатьПолучениеФайлаССервера(ПолучитьАдресДокумента(ПараметрКоманды),ПолучитьИмяИФорматФайла(ПараметрКоманды),ПараметрыДиалога);

КонецПроцедуры


&НаКлиенте
Процедура ПослеОтветаНаВопрос (РезультатВопроса, ДополнительныеПараметры) Экспорт

Если РезультатВопроса = КодВозвратаДиалога.Да Тогда
ОткрытьФорму("РегистрСведений.ЭлектронныеДокументы.Форма.ФормаЗаписи"); // Необходимо открыть форму и передать в нее значение реквизита "НаименованиеДокумента" из справочника "СписокКниг"
КонецЕсли;

КонецПроцедуры

alexandr_ll

Алексей_1985_06, А зачем вообще открывать форму записи регистра сведений?

Алексей_1985_06

alexandr_ll, Потому-что в РС хранятся электронные файлы документов, те. есть справочник который хранит названия этих документов, и при нажатии на кнопку  "Загрузить" из формы списка этих документов, происходит загрузка файла (который храниться в РС), в случае отсутствия файла в РС - выходит диалог с вопросом "Загрузить файл" и при нажатии "ДА" - необходимо открыть форму записи РС с передачей значения "Наименование документа" и в последствии загрузить файл.

alexandr_ll

Цитата: Алексей_1985_06 от 23 июл 2022, 14:11alexandr_ll, Потому-что в РС хранятся электронные файлы документов, те. есть справочник который хранит названия этих документов, и при нажатии на кнопку  "Загрузить" из формы списка этих документов, происходит загрузка файла (который храниться в РС), в случае отсутствия файла в РС - выходит диалог с вопросом "Загрузить файл" и при нажатии "ДА" - необходимо открыть форму записи РС с передачей значения "Наименование документа" и в последствии загрузить файл.
Так и не понял, почему нельзя загрузить информацию в регистр, не открывая его форму. Почему файл загружается после открытия формы, а не до этого?

Алексей_1985_06

alexandr_ll, Подскажите в таком случае пожалуйста  :dfbsdfbsdf: , как загрузить файл из модуля формы в РС?

alexandr_ll

Алексей_1985_06, Ну вы же не файл будете загружать в РС, а ссылку.
https://helpme1s.ru/registry-svedenij-v-yazyke-1s-8-v-primerax

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск