Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
03 дек 2022, 14:27

Проблема при сохранении настроек обмена для второй базы!

Автор VID1234, 21 июл 2022, 13:04

0 Пользователей и 1 гость просматривают эту тему.

VID1234

Здравствуйте. Создал собственную конфигурацию, для обмена с ЗКГУ, создал в ней правило обмена, разумеется аналогичное создал в ЗКГУ. Базой источником, должна быть моя база и она в одностороннем порядке, должна передавать только данные одного регистра сведений при изменении. Пытаюсь настроить обмен, в своей базе создаю синхронизацию (при этом выбираю план который создал я). Наименование источника, его префикс, а также наименование второй базы заполняется автоматически, префикс я указываю сам, также указываю место сохранения настроек. Сохраняю, открываю его, но у меня все наоборот, как будто бы источник ЗКГУ, а приемник моя база, что я сделал не так?
<?xml version="1.0" encoding="UTF-8"?>
<ПараметрыНастройки xmlns:v8="http://v8.1c.ru/data" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" ВерсияФормата="1.2">
    <ОсновныеПараметрыОбмена>
        <ИмяПланаОбмена xsi:type="xsd:string">ОбменБСП</ИмяПланаОбмена>
        <НаименованиеВторойБазы xsi:type="xsd:string">Управление файлами</НаименованиеВторойБазы>
        <НаименованиеЭтойБазы xsi:type="xsd:string">ЗКГУ3</НаименованиеЭтойБазы>
        <КодНовогоУзлаВторойБазы xsi:type="xsd:string">ЛТ</КодНовогоУзлаВторойБазы>
        <ПрефиксИнформационнойБазыИсточника xsi:type="xsd:string">00</ПрефиксИнформационнойБазыИсточника>
        <ВидТранспортаСообщенийОбмена xmlns="" xsi:type="EnumRef.ВидыТранспортаСообщенийОбмена">FILE</ВидТранспортаСообщенийО<wbr>�бмена>
        <ПарольАрхиваСообщенияОбмена xsi:type="xsd:string"/>
        <FILEКаталогОбменаИнформацией xsi:type="xsd:string">/mnt/1c-doc/ </FILEКаталогОбменаИнформацией>
        <FILEСжиматьФайлИсходящегоСообщения xsi:type="xsd:boolean">false</FILEСжиматьФайлИсходящегоСообщения>
        <ИспользоватьПараметрыТранспортаEMAIL xsi:type="xsd:boolean">false</ИспользоватьПараметрыТранспортаEMAIL>
        <ИспользоватьПараметрыТранспортаFILE xsi:type="xsd:boolean">true</ИспользоватьПараметрыТранспортаFILE>
        <ИспользоватьПараметрыТранспортаFTP xsi:type="xsd:boolean">false</ИспользоватьПараметрыТранспортаFTP>
        <НаименованиеНастройкиВыполненияОбмена xsi:type="xsd:string">Управление файлами</НаименованиеНастройкиВыполненияОбмена>
        <КодНовогоУзла xsi:type="xsd:string">ЛТ</КодНовогоУзла>
        <КодПредопределенногоУзла xsi:type="xsd:string">00</КодПредопределенногоУзла>
    </ОсновныеПараметрыОбмена>
</ПараметрыНастройки>
Как видите по настройкам, написано НаименованиеВторойБазы = Управление файлами, а наименованиеэтой базы = ЗКГУ3, хотя должно быть наоборот! Вручную попробовал поменять, начал загружать в ЗКГУ3, ругается, что префикс уже определен для этой базы, заново настройте синхронизацию!

а это код в менеджере объекта плана:
#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда

#Область ПрограммныйИнтерфейс

#Область ДляВызоваИзДругихПодсистем

Процедура ПриПолученииНастроек(Настройки) Экспорт
   
    Настройки.ИмяКонфигурацииИсточника = "Управление файлами";
       
    Настройки.ИмяКонфигурацииПриемника = "Зарплата и кадры государственного учреждения, редакция 3.1";
   
    Настройки.ПланОбменаИспользуетсяВМоделиСервиса = Истина;
    Настройки.ПредупреждатьОНесоответствииВерсийПравилОбмена = Истина;
   
    Настройки.Алгоритмы.ПриПолученииВариантовНастроекОбмена   = Истина;
    Настройки.Алгоритмы.ПриПолученииОписанияВариантаНастройки = Истина;
   
    Настройки.Алгоритмы.ПредставлениеОтбораИнтерактивнойВыгрузки     = Истина;
    Настройки.Алгоритмы.НастроитьИнтерактивнуюВыгрузку               = Истина;
    Настройки.Алгоритмы.НастроитьИнтерактивнуюВыгрузкуВМоделиСервиса = Истина;
   
    Настройки.Алгоритмы.ОбработчикПроверкиПараметровУчета = Ложь;
   
    Настройки.Алгоритмы.ПриПодключенииККорреспонденту     = Истина;
    Настройки.Алгоритмы.ПриПолученииДанныхОтправителя     = Истина;
   
КонецПроцедуры

Процедура ПриПолученииВариантовНастроекОбмена(ВариантыНастроекОбмена, ПараметрыКонтекста) Экспорт
   
    ВариантНастройки = ВариантыНастроекОбмена.Добавить();
    ВариантНастройки.ИдентификаторНастройки        = "Двухсторонний";
    ВариантНастройки.КорреспондентВМоделиСервиса   = Истина;
    ВариантНастройки.КорреспондентВЛокальномРежиме = Истина;
    //
    ВариантНастройки = ВариантыНастроекОбмена.Добавить();
    ВариантНастройки.ИдентификаторНастройки        = "ТолькоПолучение";
    ВариантНастройки.КорреспондентВМоделиСервиса   = Истина;
    ВариантНастройки.КорреспондентВЛокальномРежиме = Истина;
   
    ВариантНастройки = ВариантыНастроекОбмена.Добавить();
    ВариантНастройки.ИдентификаторНастройки        = "ТолькоОтправка";
    ВариантНастройки.КорреспондентВМоделиСервиса   = Истина;
    ВариантНастройки.КорреспондентВЛокальномРежиме = Истина;

КонецПроцедуры

Процедура ПриПолученииОписанияВариантаНастройки(ОписаниеВарианта, ИдентификаторНастройки, ПараметрыКонтекста) Экспорт
   
    КраткаяИнформацияПоОбмену = "";
    Если ИдентификаторНастройки = "ТолькоОтправка" Тогда
        КраткаяИнформацияПоОбмену = НСтр("ru = 'Позволяет отправлять данные из программы УФ'");
    //ИначеЕсли ИдентификаторНастройки = "Двухсторонний" Тогда
    //    КраткаяИнформацияПоОбмену = НСтр("ru = 'Позволяет синхронизировать данные ОбменБСП'");
    КонецЕсли;
   
    ПодробнаяИнформацияПоОбмену = ?(ОбщегоНазначения.РазделениеВключено(),
        "https://its.1c.ru/bmk/bsp/synch_prog",
        "ПланОбмена.ОбменБСП.Форма.ПодробнаяИнформация");
   
    ОписаниеВарианта.КраткаяИнформацияПоОбмену   = КраткаяИнформацияПоОбмену;
    ОписаниеВарианта.ПодробнаяИнформацияПоОбмену = ПодробнаяИнформацияПоОбмену;
   
    ОписаниеВарианта.ИмяКонфигурацииКорреспондента          = Метаданные.Имя;
    ОписаниеВарианта.НаименованиеКонфигурацииКорреспондента = НСтр("ru = 'ЗКГУ3'");
    ОписаниеВарианта.ИмяФайлаНастроекДляПриемника           = НСтр("ru = 'ФайлНастроекОбменБСП'");
   
    ОписаниеВарианта.ПутьКФайлуКомплектаПравилНаПользовательскомСайте = "https://users.v8.1c.ru/distribution/project/SSL22";
    ОписаниеВарианта.ПутьКФайлуКомплектаПравилВКаталогеШаблонов       = "1c\SSL\";
   
    ЗаголовокКоманды   = "";
    ЗаголовокПомощника = "";
    ЗаголовокУзла      = "";
   
    Если ИдентификаторНастройки = "ТолькоОтправка" Тогда
       
        ЗаголовокКоманды   = НСтр("ru = 'Отправка данных из УФ'");
        ЗаголовокПомощника = НСтр("ru = 'Отправка данных из УФ (нстройка)'");
        ЗаголовокУзла      = НСтр("ru = 'Отправка данных из УФ'");
       
    //ИначеЕсли ИдентификаторНастройки = "Двухсторонний" Тогда
    //   
    //    ЗаголовокКоманды   = НСтр("ru = 'Полная синхронизация данных с ""ОбменБСП""'");
    //    ЗаголовокПомощника = НСтр("ru = 'Синхронизация данных с ОбменБСП (настройка)'");
    //    ЗаголовокУзла      = НСтр("ru = 'Синхронизация данных с 1С:ОбменБСП'");
       
    КонецЕсли;
   
    ОписаниеВарианта.ЗаголовокКомандыДляСозданияНовогоОбменаДанными = ЗаголовокКоманды;
    ОписаниеВарианта.ЗаголовокПомощникаСозданияОбмена               = ЗаголовокПомощника;
    ОписаниеВарианта.ЗаголовокУзлаПланаОбмена                       = ЗаголовокУзла;
   
    ПояснениеДляНастройкиПараметровУчета = НСтр("ru = 'Требуется указать ответственных для организаций.
        |Для этого перейдите в раздел ""Синхронизация данных"" и выберите команду ""Ответственные лица организаций"".'");
    ОписаниеВарианта.ПояснениеДляНастройкиПараметровУчета = ПояснениеДляНастройкиПараметровУчета;
   
    ОписаниеВарианта.ОбщиеДанныеУзлов = "ДатаНачалаВыгрузкиДокументов, РежимВыгрузкиСправочников, "
        + "РежимВыгрузкиСправочниковКорреспондента, РежимВыгрузкиДокументов, РежимВыгрузкиДокументовКорреспондента, "
        + "ИспользоватьОтборПоПодразделениям, ИспользоватьОтборПоСкладам, Подразделения, Склады";
   
КонецПроцедуры

Процедура ОбработчикПроверкиПараметровУчета(Отказ, Получатель, Сообщение) Экспорт
   
    Отбор = Неопределено;
   
    СвойстваПолучателя = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(Получатель, "ИспользоватьОтборПоОрганизациям, Организации");
   
    Если СвойстваПолучателя.ИспользоватьОтборПоОрганизациям Тогда
       
        Отбор = СвойстваПолучателя.Организации.Выгрузить().ВыгрузитьКолонку("Организация");
       
    КонецЕсли;
   
    Если Не РегистрыСведений._ДемоОтветственныеЛица.ДляВсехОрганизацийНазначеныОтветственные(Отбор, Сообщение) Тогда
       
        Отказ = Истина;
       
    КонецЕсли;
   
КонецПроцедуры

Процедура ПриПодключенииККорреспонденту(ВерсияКорреспондента) Экспорт
   
    Если ВерсияКорреспондента = "0.0.0.0" Тогда
        ВерсияКорреспондента = "2.0.1.1";
    КонецЕсли;
   
    Если ОбщегоНазначенияКлиентСервер.СравнитьВерсии(ВерсияКорреспондента, "1.0.6.8") < 0 Тогда
       
        ВызватьИсключение НСтр("ru = 'Настройка синхронизации данных поддерживается только с демонстрационной конфигурацией
            |""Библиотека стандартных подсистем"" версии 1.0.6 и выше.'");
    КонецЕсли;
   
КонецПроцедуры

Процедура ПриПолученииДанныхОтправителя(Отправитель, Игнорировать) Экспорт
   
    Если ТипЗнч(Отправитель) = Тип("Структура") Тогда
       
        Если Отправитель.Свойство("РежимВыгрузкиСправочников") Тогда
            ПоменятьЗначения(Отправитель, "РежимВыгрузкиСправочников", "РежимВыгрузкиСправочниковКорреспондента");
        КонецЕсли;
       
        Если Отправитель.Свойство("РежимВыгрузкиДокументов") Тогда
            ПоменятьЗначения(Отправитель, "РежимВыгрузкиДокументов", "РежимВыгрузкиДокументовКорреспондента");
        КонецЕсли;
       
    Иначе
       
        ПоменятьЗначения(Отправитель, "РежимВыгрузкиСправочников", "РежимВыгрузкиСправочниковКорреспондента");
        ПоменятьЗначения(Отправитель, "РежимВыгрузкиДокументов", "РежимВыгрузкиДокументовКорреспондента");
       
    КонецЕсли;
   
КонецПроцедуры


Процедура НастроитьИнтерактивнуюВыгрузку(Получатель, Параметры) Экспорт
   
    // Настраиваем стандартные варианты.
    Параметры.ВариантБезДополнения.Использование     = Истина;
    Параметры.ВариантБезДополнения.Порядок           = 2;
    Параметры.ВариантВсеДокументы.Использование      = Ложь;
    Параметры.ВариантПроизвольныйОтбор.Использование = Ложь;
   
    // Настраиваем вариант дополнения по сценарию узла.
    Параметры.ВариантДополнительно.Использование  = Истина;
    Параметры.ВариантДополнительно.Порядок        = 1;
    Параметры.ВариантДополнительно.Заголовок      = НСтр("ru = 'Отправить поступления товаров по организациям:'");
    Параметры.ВариантДополнительно.Пояснение      = НСтр("ru = 'Дополнительно будут отправлены документы поступления товаров за указанный период по выбранным организациям.'");
   
    Параметры.ВариантДополнительно.ИмяФормыОтбора        = "ПланОбмена.ОбменБСП.Форма.НастройкаВыгрузки";
    Параметры.ВариантДополнительно.ЗаголовокКомандыФормы = НСтр("ru = 'Выбрать организации'");
   
    // Вычисляем и устанавливаем параметры сценария.
    ПараметрыПоУмолчанию = ПараметрыВыгрузкиПоУмолчанию(Получатель);
   
    Параметры.ВариантДополнительно.ИспользоватьПериодОтбора = Истина;
    Параметры.ВариантДополнительно.ПериодОтбора = ПараметрыПоУмолчанию.Период;
   
    // Добавляем строку настройки отбора.
    СтрокаОтбора = Параметры.ВариантДополнительно.Отбор.Добавить();
    СтрокаОтбора.ПолноеИмяМетаданных = "Документ._ДемоПоступлениеТоваров";
    СтрокаОтбора.ВыборПериода = Истина;
    СтрокаОтбора.Период       = ПараметрыПоУмолчанию.Период;
    СтрокаОтбора.Отбор        = ПараметрыПоУмолчанию.Отбор;
   
КонецПроцедуры


Функция ПредставлениеОтбораИнтерактивнойВыгрузки(Получатель, Параметры) Экспорт
   
    Если Параметры.ИспользоватьПериодОтбора Тогда
        Если ЗначениеЗаполнено(Параметры.ПериодОтбора) Тогда
            ОписаниеПериода = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'за период: %1'"), НРег(Параметры.ПериодОтбора));
        Иначе
            ДатаНачалаВыгрузки = Получатель.ДатаНачалаВыгрузкиДокументов;
            Если ЗначениеЗаполнено(ДатаНачалаВыгрузки) Тогда
                ОписаниеПериода = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                    НСтр("ru = 'начиная с даты начала отправки документов: %1'"), Формат(ДатаНачалаВыгрузки, "ДЛФ=DD"));
            Иначе
                ОписаниеПериода = НСтр("ru = 'за весь период учета'");
            КонецЕсли;
        КонецЕсли;
    Иначе
        ОписаниеПериода = "";
    КонецЕсли;
   
    СписокОрганизаций = ОрганизацииОтбораИнтерактивнойВыгрузки(Параметры.Отбор);
    Если СписокОрганизаций.Количество()=0 Тогда
        ОписаниеОтбораОрганизации = НСтр("ru = 'по всем организациям'");
    Иначе
        ОписаниеОтбораОрганизации = "";
        Для Каждого Элемент Из СписокОрганизаций Цикл
            ОписаниеОтбораОрганизации = ОписаниеОтбораОрганизации+ ", " + Элемент.Представление;
        КонецЦикла;
        ОписаниеОтбораОрганизации = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru = 'по организациям: %1'"), СокрЛП(Сред(ОписаниеОтбораОрганизации, 2)));
    КонецЕсли;

    Возврат СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
        НСтр("ru = 'Будут отправлены поступления товаров %1,
                 |%2'"),
        ОписаниеПериода,  ОписаниеОтбораОрганизации);
КонецФункции


Процедура НастроитьИнтерактивнуюВыгрузкуВМоделиСервиса(Получатель, Параметры) Экспорт
   
    Параметры.ВариантБезДополнения.Использование     = Истина;
    Параметры.ВариантВсеДокументы.Использование      = Истина;
    Параметры.ВариантПроизвольныйОтбор.Использование = Истина;
   
КонецПроцедуры

.
Функция РеквизитыНеРедактируемыеВГрупповойОбработке() Экспорт
   
    Результат = Новый Массив;
    Результат.Добавить("РегистрироватьИзменения");
    Возврат Результат;
   
КонецФункции


Функция ОрганизацииОтбораИнтерактивнойВыгрузки(Знач ТаблицаОтбора) Экспорт
   
    Результат = Новый СписокЗначений;
   
    Если ТаблицаОтбора.Количество()=0 Или ТаблицаОтбора[0].Отбор.Элементы.Количество()=0 Тогда
        // Нет данных отбора
        Возврат Результат;
    КонецЕсли;
       
    // Мы знаем состав отбора, так как помещали туда сами - или из "НастроитьИнтерактивнуюВыгрузку"
    // или как результат редактирования в форме.
   
    СтрокаДанных = ТаблицаОтбора[0].Отбор.Элементы[0];
    Отобранные   = СтрокаДанных.ПравоеЗначение;
    ТипКоллекции = ТипЗнч(Отобранные);
   
    Если ТипКоллекции = Тип("СписокЗначений") Тогда
        Для Каждого Элемент Из Отобранные Цикл
            ДобавитьСписокОрганизаций(Результат, Элемент.Значение);
        КонецЦикла;
       
    ИначеЕсли ТипКоллекции = Тип("Массив") Тогда
        ДобавитьСписокОрганизаций(Результат, Отобранные);
         
    ИначеЕсли ТипКоллекции = Тип("СправочникСсылка._ДемоОрганизации") Тогда
        Если Результат.НайтиПоЗначению(Отобранные) = Неопределено Тогда
            Результат.Добавить(Отобранные, Отобранные.Наименование);
        КонецЕсли;
       
    КонецЕсли;
   
    Возврат Результат;
КонецФункции


Процедура ДобавитьСписокОрганизаций(Список, Знач Организации)
    Для Каждого Организация Из Организации Цикл
       
        Если ТипЗнч(Организация)=Тип("Массив") Тогда
            ДобавитьСписокОрганизаций(Список, Организация);
            Продолжить;
        КонецЕсли;
       
        Если Список.НайтиПоЗначению(Организация)=Неопределено Тогда
            Список.Добавить(Организация, Организация.Наименование);
        КонецЕсли;
       
    КонецЦикла;
КонецПроцедуры

Процедура ПоменятьЗначения(Данные, Знач Свойство1, Знач Свойство2)
   
    Значение = Данные[Свойство1];
   
    Данные[Свойство1] = Данные[Свойство2];
    Данные[Свойство2] = Значение;
   
КонецПроцедуры


Функция ПараметрыВыгрузкиПоУмолчанию(Получатель)
   
    Результат = Новый Структура;
   
    // Период по умолчанию
    Результат.Вставить("Период", Новый СтандартныйПериод);
    Результат.Период.Вариант = ВариантСтандартногоПериода.ПрошлыйМесяц;
   
    // Отбор по умолчанию и его представление.
    КомпоновщикОтбора = Новый КомпоновщикНастроекКомпоновкиДанных;
    Результат.Вставить("Отбор", КомпоновщикОтбора.Настройки.Отбор);
   
    ОтборПоОрганизации = Результат.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ОтборПоОрганизации.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("Ссылка.Организация");
    ОтборПоОрганизации.ВидСравнения   = ВидСравненияКомпоновкиДанных.ВСписке;
    ОтборПоОрганизации.Использование  = Истина;
    ОтборПоОрганизации.ПравоеЗначение = Новый Массив;
   
    // Элементы, предлагаемые первый раз по умолчанию, считываем из настроек узла.
    Если Получатель.ИспользоватьОтборПоОрганизациям Тогда
        // Организации из табличной части.
        ЗапросИсточника = Новый Запрос("
            |ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    ОрганизацииПланаОбмена.Организация              КАК Организация,
            |    ОрганизацииПланаОбмена.Организация.Наименование КАК Наименование
            |ИЗ
            |    ПланОбмена.ОбменБСП.Организации КАК ОрганизацииПланаОбмена
            |ГДЕ
            |    ОрганизацииПланаОбмена.Ссылка = &Получатель
            |");
        ЗапросИсточника.УстановитьПараметр("Получатель", Получатель);
    Иначе
        // Все доступные организации
        ЗапросИсточника = Новый Запрос("
            |ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    Организации.Ссылка       КАК Организация,
            |    Организации.Наименование КАК Наименование
            |ИЗ
            |    Справочник.Организации КАК Организации
            |ГДЕ
            |    НЕ Организации.ПометкаУдаления
            |");
    КонецЕсли;
       
    ОтборПоОрганизацииСтрокой = "";
    Выборка = ЗапросИсточника.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        ОтборПоОрганизации.ПравоеЗначение.Добавить(Выборка.Организация);
        ОтборПоОрганизацииСтрокой = ОтборПоОрганизацииСтрокой + ", " + Выборка.Наименование;
    КонецЦикла;
    ОтборПоОрганизацииСтрокой = СокрЛП(Сред(ОтборПоОрганизацииСтрокой, 2));
   
    // Общее представление, период не включаем, так как в этом сценарии поле периода будет редактироваться отдельно.
    Результат.Вставить("ПредставлениеОтбора", СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
        НСтр("ru = 'Будут отправлены поступления товаров по организациям:
                 |%1'"),
        ОтборПоОрганизацииСтрокой));
   
    Возврат Результат;
КонецФункции

Процедура ОпределитьРежимыВыгрузкиДокументов(Знач ВариантСинхронизацииДокументов, Знач Данные) Экспорт
   
    Если ВариантСинхронизацииДокументов = "ОтправлятьИПолучатьАвтоматически" Тогда
       
        Данные.РежимВыгрузкиДокументов               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
        Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
       
    ИначеЕсли ВариантСинхронизацииДокументов = "ОтправлятьАвтоматически" Тогда
       
        Данные.РежимВыгрузкиДокументов               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
        Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
       
    ИначеЕсли ВариантСинхронизацииДокументов = "ПолучатьАвтоматически" Тогда
       
        Данные.РежимВыгрузкиДокументов               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
        Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
       
    ИначеЕсли ВариантСинхронизацииДокументов = "ОтправлятьИПолучатьВручную" Тогда
       
        Данные.РежимВыгрузкиДокументов               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
        Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
       
    КонецЕсли;
   
КонецПроцедуры

Процедура ОпределитьРежимыВыгрузкиСправочников(Знач ВариантСинхронизацииСправочников, Знач Данные) Экспорт
   
    Если ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьАвтоматически" Тогда
       
        Данные.РежимВыгрузкиСправочников               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
        Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
       
    ИначеЕсли ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьПриНеобходимости" Тогда
       
        Данные.РежимВыгрузкиСправочников               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости;
        Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости;
       
    ИначеЕсли ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьВручную" Тогда
       
        Данные.РежимВыгрузкиСправочников               = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
        Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную;
       
    КонецЕсли;
   
КонецПроцедуры

Процедура ОпределитьВариантСинхронизацииДокументов(ВариантСинхронизацииДокументов, Знач Данные) Экспорт
   
    Если Данные.РежимВыгрузкиДокументов                = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию
        И Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию Тогда
       
        ВариантСинхронизацииДокументов = "ОтправлятьИПолучатьАвтоматически"
       
    ИначеЕсли Данные.РежимВыгрузкиДокументов           = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию
        И Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную Тогда
       
        ВариантСинхронизацииДокументов = "ОтправлятьАвтоматически"
       
    ИначеЕсли Данные.РежимВыгрузкиДокументов           = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную
        И Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию Тогда
       
        ВариантСинхронизацииДокументов = "ПолучатьАвтоматически"
       
    ИначеЕсли Данные.РежимВыгрузкиДокументов           = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную
        И Данные.РежимВыгрузкиДокументовКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную Тогда
       
        ВариантСинхронизацииДокументов = "ОтправлятьИПолучатьВручную"
       
    КонецЕсли;
   
КонецПроцедуры

Процедура ОпределитьВариантСинхронизацииСправочников(ВариантСинхронизацииСправочников, Знач Данные) Экспорт
   
    Если Данные.РежимВыгрузкиСправочников                = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию
        И Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию Тогда
       
        ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьАвтоматически"
       
    ИначеЕсли Данные.РежимВыгрузкиСправочников           = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости
        И Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости Тогда
       
        ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьПриНеобходимости"
       
    ИначеЕсли Данные.РежимВыгрузкиСправочников           = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную
        И Данные.РежимВыгрузкиСправочниковКорреспондента = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьВручную Тогда
       
        ВариантСинхронизацииСправочников = "ОтправлятьИПолучатьВручную"
       
    КонецЕсли;
   
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск