Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 авг 2022, 12:41

вывести строку перед универсальным отчетом

Автор anna_m, 18 июл 2022, 09:44

0 Пользователей и 1 гость просматривают эту тему.

anna_m

Добрый день!

УПП, отчет по партиям на основе универсального отчета.

Перед самой таблицей отчета надо вывести пару строк для бух.

Сделала макет, а вызов не срабатывает.

В инете пишут,что для типовых отчетов нет такой возможности.

Так ли это?

LexaK

anna_m, отчет это табличный документ, после формирования у вас есть форма с табличным документом...
А в табличный документ, в ЛЮБОЕ место, можно вставить область (а в ней все что угодно, текст, картинки)
если помогло нажмите: Спасибо!

anna_m

LexaK, там отсылка к формированию универсального отчета.

ЦитироватьУниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент,,, ЭтотОбъект);

если я добавляю свою функцию перед формированием универсального отчета, она не отрабатывает.
Менять механизм универсального отчета, понятное дело, не буду.
Копировать все функции из формирования универсального остается?

LexaK

anna_m, так вот же ссылка
УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент,,, ЭтотОбъект);
ТабличныйДокумент - ссылка на табличный документ!
после выполнения этой команды, наверняка там сам отчет!
если то так, то в него, вставкой добавьте область с нужным текстом
если помогло нажмите: Спасибо!

anna_m

LexaK,
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
   
   
    // Перед формирование отчета можно установить необходимые параметры универсального отчета.
     Макет = ПолучитьМакет("Макет");   
   
   
    Шапка = Макет.ПолучитьОбласть("ШапкаОтчета");
   
    Шапка.Параметры.КодПодр = ЭтотОбъект.ПодразделениеОтчета.Код;
    Шапка.Параметры.ПодразделениеОтчета = ЭтотОбъект.ПодразделениеОтчета;
    Шапка.Параметры.МолОтчета = ЭтотОбъект.МолОтчета;

    ТабличныйДокумент.Вывести(Шапка);
   
    УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент,,, ЭтотОбъект);
    КонецПроцедуры // СформироватьОтчет()


не выводит  :dfbbdrfb:

LexaK

anna_m, а этот вывод шапки был или вы добавили?
если помогло нажмите: Спасибо!

anna_m

я добавила
изначально была одна строка
УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент,,, ЭтотОбъект);

LexaK

anna_m, попробуйте такой код
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт

ТабДок = Новый ТабличныйДокумент;
    УниверсальныйОтчет.СформироватьОтчет(ТабДок,,, ЭтотОбъект);
   
    // Перед формирование отчета можно установить необходимые параметры универсального отчета.
    Макет = ПолучитьМакет("Макет");   
    Шапка = Макет.ПолучитьОбласть("ШапкаОтчета");
   
    Шапка.Параметры.КодПодр = ЭтотОбъект.ПодразделениеОтчета.Код;
    Шапка.Параметры.ПодразделениеОтчета = ЭтотОбъект.ПодразделениеОтчета;
    Шапка.Параметры.МолОтчета = ЭтотОбъект.МолОтчета;

    ТабличныйДокумент.Вывести(Шапка);
    ТабличныйДокумент.Вывести(ТабДок);

КонецПроцедуры // СформироватьОтчет()

если помогло нажмите: Спасибо!

anna_m

LexaK, действительно помогло, спасибо огромное!
Только поехал отчет, подскажете, как вернуть в изначальное состояние?

Безымянный.jpg 

LexaK

anna_m, ааа, это какие-то пляски с индивидуальным форматом ячеек нужны
(вот! первая идея, добавить область в табдок, ПОСЛЕ формирования отчета, была вернее)
попробуйте так (доп. текст потом сами дополните)

Процедура СформироватьОтчет(ТабДок) Экспорт

    УниверсальныйОтчет.СформироватьОтчет(ТабДок,,, ЭтотОбъект);

ТабДок.ВставитьОбласть(ТабДок.Область("R1"), ТабДок.Область("R1"),
        ТипСмещенияТабличногоДокумента.ПоВертикали);

ТабДок.Область("R1").Очистить();
ТабДок.Область("R1C1").Текст = "Подразделение: (" + ЭтотОбъект.ПодразделениеОтчета.Код + ")"
+ ЭтотОбъект.ПодразделениеОтчета;


КонецПроцедуры // СформироватьОтчет()

если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск