Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2022, 05:26

выделение ячейки ТЧ документа цветом

Автор anna_m, 05 июл 2022, 15:25

0 Пользователей и 1 гость просматривают эту тему.

anna_m

Добрый день!

Задача банальная, а информация на просторах интернета не помогает.

Есть допотопная УПП, на обычных формах.

Задача: в ТАБЛИЧНОЙ ЧАСТИ документа в строке

если СуммаБУ <> СуммаНУ

изменить цвет шрифта / выделить такие строки, чтобы после выравнивания цифр выделение снималось.

LexaK

anna_m, (давно это было, обычные формы)
в форме документа, есть обработчик события ПриПолученииДанных
так как раз можно пробежаться циклом по ТЧ, в условии Если сравнить Суммы и если различаются то задать Цвет Шрифта

почитайте или найдите пример у себя в базе (наверняка уже кто-то раскрашивал что-то)
ТабличноеПоле (TableBox)
ПриПолученииДанных (OnDataGet)
Синтаксис:
ПриПолученииДанных(<ОформленияСтрок>)
Параметры:
<ОформленияСтрок>
Тип: ОформленияСтрок.
Коллекция оформления строк табличного поля.
Данную коллекцию нельзя использовать вне обработчика, т.к в момент вызова обработчика события она напрямую связана с коллекцией видимых строк табличного поля, а после окончания обработки события ее содержимое может не соответствовать коллекции видимых строк.
Описание:
Возникает при получении данных табличным полем, после обработки событий ПриВыводеСтроки.
если помогло нажмите: Спасибо!

anna_m

LexaK, про обработчик события читала, но не могу найти как его открыть, в свойствах формы не нахожу :dfbsdfbsdf:

LexaK

 anna_m, (еще раз) глобальным поиском, в конфигураторе своей базы, поищите такую команду
ПриПолученииДанных

и на ее примере сделайте свою раскраску!
если помогло нажмите: Спасибо!

antoneus

ПриВыводеСтроки больше подходит, там же и ДанныеСтроки есть.
И это событие не в свойствах формы, а в свойствах табличного поля.

LexaK

anna_m, вот какой то пример нашел, (свои наименования подставьте)

Процедура ТабЧастьПриПолученииДанных(Элемент, ОформленияСтрок)
Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
Если ВашеУсловие Тогда
ОформлениеСтроки.Ячейки.Статус.ЦветФона = WebЦвета.Желтый;
ОформлениеСтроки.Ячейки.Статус.ЦветТекста = WebЦвета.Красный;
Иначе
ОформлениеСтроки.Ячейки.Статус.ЦветФона = WebЦвета.Белый;
ОформлениеСтроки.Ячейки.Статус.ЦветТекста = WebЦвета.Черный;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

если помогло нажмите: Спасибо!

anna_m

LexaK, сделала, подсвечивается весь столбец  :xfbnsdfb:
При перезаполнении ТЧ - подсветка слетает вообще

Вопрос такой - если мне в документе нужна кнопка Проверки сумм НУ и БУ после того, как ТЧ стотыщ раз перезаполнится, там я выделение цветом уже не добавлю?

LexaK

anna_m, не понимаю ваши трудности, выделение цветом - это обычная команда,
такие команды собирают в процедуры УсловноеОформление() и вызывают в нужных местах и событиях, столько сколько нужно для правильного и красивого отображения данных!
если помогло нажмите: Спасибо!

antoneus


anna_m

LexaK, ну, видимо, раскрашивание - это не мое  :dfbsdfbsdf:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск