Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 авг 2022, 12:28

Установить заголовок системы по названию структуры

Автор Магистратиум, 02 июл 2022, 16:09

0 Пользователей и 1 гость просматривают эту тему.

Магистратиум

Добрый день.
Необходимо при запуске 1С, параметру сеанса присвоить значение первой попавшейся в справочнике структуре. Далее заголовок системы установить по значению параметры структуры.
С создание параметра структуры справился )))

Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
    ПараметрыСеанса.ТекущаяСтрутурнаяЕдиница="12345";   
КонецПроцедуры

Процедура ПриНачалеРаботыСистемы()
    мПерем=ТекСтрЕд.ТекущСтруктурЕдин();
    КлиентскоеПриложение.УстановитьЗаголовок(мПерем);
КонецПроцедуры

Функция ТекущСтруктурЕдин () Экспорт
Имя=ПараметрыСеанса.ТекущаяСтрутурнаяЕдиница;
Возврат Имя;
КонецФункции


С какой-либо константой получилось, а вот выдернуть значение из справочника не получается... Помогите....
Спасибо.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск