Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
04 июл 2022, 09:02

Ошибка при нажатии ОБМЕН ДАННЫМИ между филиалами в режиме 1С Предприятие

Автор НикNik, 23 июн 2022, 18:34

0 Пользователей и 1 гость просматривают эту тему.

НикNik

Всем Добрый день. В режиме 1С Предприятие при нажатии кнопки ОБМЕН ДАННЫМИ выскакивает ошибка "Операция сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов". Код ниже:
&НаСервереБезКонтекста
Процедура ВыполнитьОбменНаСервере() Экспорт

ВыборкаУзлов = ПланыОбмена.Филиалы.Выбрать();

Пока ВыборкаУзлов.Следующий() Цикл

// Произвести обмен данными со всеми узлами, кроме текущего (ЭтотУзел).
  Если ВыборкаУзлов.Ссылка > ПланыОбмена.Филиалы.ЭтотУзел() Тогда
УзелОбъект = ВыборкаУзлов.ПолучитьОбъект();

// Получить сообщение.
УзелОбъект.ПрочитатьСообщениеСИзменениями();

// Сформировать сообщение.
УзелОбъект.ЗаписатьСообщениеСИзменениями();

КонецЕсли;

КонецЦикла;

КонецПроцедуры
 
Никогда не поздно учиться...

LexaK

НикNik, попробуйте такую поманду
Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда
если помогло нажмите: Спасибо!

НикNik

Цитата: LexaK от 24 июн 2022, 10:12НикNik, попробуйте такую поманду
Если ВыборкаУзлов.Ссылка <> ПланыОбмена.Филиалы.ЭтотУзел() Тогда
Вы как всегда правы, спасибо вам.
Никогда не поздно учиться...

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск