Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 ноя 2022, 13:09

Заполнение табличной части документа из другого документа

Автор Алёна_Крас, 23 июн 2022, 13:32

0 Пользователей и 1 гость просматривают эту тему.

Алёна_Крас

Есть "Документ1" с табличной частью, у него есть кнопка "Выбрать" при нажатии выходит список документов "Документ2"...щелкая по ним они добавляются в табл. часть "Документ1". Как сразу сделать отбор в открывающейся Форме выбора по определенному реквизиту? Помогите, пожалуйста. Заранее, Огромное спасибо)))

&НаКлиенте
Процедура ДобавитьПролив(Команда)
       ПараметрыФормыВыбора = Новый Структура;
       ПараметрыФормыВыбора.Вставить("ЗакрыватьПриВыборе", Истина);
    ПараметрыФормыВыбора.Вставить("МножественныйВыбор", Истина);
   
    ОткрытьФорму("Документ.ПополнениеТопливныхКарт.ФормаВыбора",
    ПараметрыФормыВыбора,ЭтаФорма,,,,Новый ОписаниеОповещения("ВыборПроливаЗавершение", ЭтотОбъект), РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
КонецПроцедуры

&НаКлиенте
Процедура ВыборПроливаЗавершение(Результат, ДополнительныеПараметры) Экспорт
    Если ЗначениеЗаполнено(Результат) И ТипЗнч(Результат) = Тип("Массив") Тогда
        ЗаполнитьТЧПроливы(Результат);
    КонецЕсли;
КонецПроцедуры
       
&НаСервере
Процедура ЗаполнитьТЧПроливы(МассивРезультатов)
    Для Каждого ЭлементМассива Из МассивРезультатов Цикл
        нСтрока = Объект.Проливы.Добавить();
        ЗаполнитьЗначенияСвойств(нСтрока, ЭлементМассива);//Реквизиты ТЧ и Документа1 которые будут заполнены должны иметь одинаковое имя
    КонецЦикла;
КонецПроцедуры

LexaK

Алёна_Крас, прямо на элементе, при начале выбора, работает такой код,
здесь как раз добавлен Отбор по реквизиту Номенклатуры, сможете переделать под свою задачу
&НаКлиенте
Процедура ПереченьНоменклатурыНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

ПараметрыПодбора = Новый Структура;
ПараметрыПодбора.Вставить("РежимВыбора", Истина);
ПараметрыПодбора.Вставить("ЗакрыватьПриВыборе", Истина);
ПараметрыПодбора.Вставить("МножественныйВыбор", Ложь);
ПараметрыПодбора.Вставить("Отбор", Новый Структура("ВидНоменклатуры", ПредопределенноеЗначение("Перечисление.ВидыНоменклатуры.Материалы")));

ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", ПараметрыПодбора, Элемент);


КонецПроцедуры

если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск