Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
04 июл 2022, 09:40

Ошибка при выгрузке в эксель файл на сервере "Нет доступа к файлу..."

Автор Черника, 22 июн 2022, 12:50

0 Пользователей и 1 гость просматривают эту тему.

Черника

Помогите пожалуйста.
При работе обработки по расписанию выгрузке информации в эксель файл на БД установленной на ПК все отрабатывает без ошибок, при выгрузке из БД на  Сервере выдается ошибка Screenshot_1.png


 
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт   
   
// Реализация логики команды
Если ИдентификаторКоманды = "ВыгрузкаИнформацииПоОбработкам" Тогда
СсылкаНаОрганизацию = Справочники.Организации.НайтиПоКоду("000000001"); 
ИНН = СсылкаНаОрганизацию.ИНН;

Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.DisplayAlerts = 0;
        Excel.Visible = 0;
    Исключение
           Сообщить(ОписаниеОшибки() + " Программа Exсel не установлена");
           Возврат;
       КонецПопытки;
       
       Книга = Excel.Workbooks.Open("\\ivn-srv-25\d$\Buh_Base_8\Обработки\1.xlsx");
       
ЛистСуществует = Ложь;
КоличествоЛистов = Книга.Sheets.Count;
Для НомерЛиста = 1 По КоличествоЛистов Цикл
Если Книга.Sheets(НомерЛиста).Name = ИНН Тогда
ЛистСуществует = Истина;
КонецЕсли;
КонецЦикла;

Если Не ЛистСуществует Тогда
Лист = Книга.WorkSheets.Add();
Лист.Name = ИНН;
КонецЕсли;

    Книга.Save();
    Excel.Workbooks.Close();
    Excel.Application.Quit();



   
КонецЕсли;
КонецПроцедуры

wise

(0) к файлу ДОЛЖЕН иметь доступ пользователь сервера приложений...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Черника


wise

(2) Вы работаете интерактивно в 1С и у Вас права пользователя "Черника", которому доступны ресурсы \\inthjdkh\buh_base8\обработки\1.xlsx
но когда 1С'ка САМА что-то пытается СДЕЛАТЬ, то ГДЕ-ТО на сервере приложений запускается DefUser и выполняет задание.
так ВОТ этот пользователь под которым запущен сервер приложений и ДОЛЖЕН иметь ДОСТУП к {\\inthjdkh\buh_base8\обработки\1.xlsx}
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск