Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 15:10

Данные из РегистраСведения в Строку ТЧ документа

Автор PtAxAbc, 17 июн 2022, 09:33

0 Пользователей и 1 гость просматривают эту тему.

PtAxAbc

Приветствую. Попробую попросить здесь помощи, так как запутался. В документе Производство, после выбора номенклатуры, нужно получить число в ячейку из РегистрПоказатели где храняться показатели по СтруктурнойЕдинице, последний по дате, по Номенклатуре
&НаСервере
Процедура ЗапросКол_Т ()
   //****160622
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |    РегистрПоказателиСрезПоследних.Номенклатура КАК Номенклатура,
   |    РегистрПоказателиСрезПоследних.Кво_П КАК Кво_П
   |ИЗ
   |    РегистрСведений.РегистрПоказатели.СрезПоследних(, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК РегистрПоказателиСрезПоследних
   |ВНУТРЕННЕЕ СОЕДИНЕНИЕ
   |Документ.СборкаЗапасов.Продукция КАК Продукция
   |ПО
   |РегистрПоказателиСрезПоследних.Номенклатура = Продукция.Номенклатура
   |ГДЕ
   |Продукция.Ссылка = &СсылкаНаДокумент";
   Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Объект.СтруктурнаяЕдиница);
   Запрос.УстановитьПараметр("СсылкаНаДокумент", Объект.Ссылка);
   
   ТаблицаРезультата = Запрос.Выполнить().Выгрузить();
   Для Каждого СтрокаПродукция Из Объект.Продукция Цикл
      СтрокаИзЗапроса = ТаблицаРезультата.Найти(СтрокаПродукция.Номенклатура, "Номенклатура");
      Если СтрокаИзЗапроса = Неопределено Тогда
         Сообщить("Для товара " + СтрокаПродукция.Номенклатура.Наименование +" нет записи в регистре показателей");   
      Иначе
         СтрокаПродукция.Кол_Р = СтрокаИзЗапроса.Кво_П;
      КонецЕсли;
   КонецЦикла;   
КонецПроцедуры
***
Сейчас результат - нет записи в регистре......

LexaK

PtAxAbc,
ЦитироватьСейчас результат - нет записи в регистре......
так это не ошибка!!!

нет записей! просто их надо добавить в регистр!!! и у вас все будет работать!
(при этом проверить Типы данных, условия, сравнения и др.)
если помогло нажмите: Спасибо!

PtAxAbc


Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск