Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 13:45

Куда правильней в Регистр Остатков или Сведений?

Автор Алексей Корольков, 15 июн 2022, 16:54

0 Пользователей и 1 гость просматривают эту тему.

Алексей Корольков

 :wacko:

Приветствую!

Решаю вполне стандартную задачку но туплю целый день и никак не соображу как правильней.

Суть задачи: Есть "Приходная Накладная" по которой поступают товары и услуги и есть "Расходная накладная" по которой списываются товары. И тут возникает вопрос : Как и куда что списывается и добавляется?
Понятно что на сладе храниться услуги не могут и куда их тогда записывать ? И со склада списываться услуги то же не могут, но как тогда учитывать услуги вместе с товарами в регистрах в сумме "итого"?

Небольшой код из "Расходной Накладной" и дальше дело не идёт:

Процедура ОбработкаПроведения(Отказ, Режим)
Движения.ОстаткиМатериалов.Записывать = Истина;
Движения.СтоимостьМатериалов.Записывать = Истина;
Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
Если ТекСтрокаПереченьНоменклатуры.Номенклатура.ВидНоменклатуры = Перечисления.ВидыНоменклатуры.Товар Тогда

// Регистр ОстаткиМатериалов Расход
Движение = Движения.ОстаткиМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Склад = Склад;
Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;

// Регистр СтоимостьМатериалов Расход
Движение = Движения.СтоимостьМатериалов.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
Движение.Стоимость = ТекСтрокаПереченьНоменклатуры.Количество * ТекСтрокаПереченьНоменклатуры.Стоимость;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

LexaK

Алексей Корольков, в остатки, писать услуги, действительно не стоит!
а вот в регистрнакопления Выручка и Взаиморасчеты (если их нет, создайте) стоит
а как вы вообще планировали прибыль считать? а расчеты с покупателями/поставщиками? кто кому сколько должен?
помимо остатков РН, еще предоставляют и результаты по Оборотам!
например: за месяц, на какую сумму было оказано Услуг? (легко получить из регистров)
если помогло нажмите: Спасибо!

wise

(0) товары и услуги пишите в ОБОРОТНЫЙ регистр "Продажи".
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск