Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2022, 17:02

При входе пользователя в конфигурацию необходимо проверять соответствует ли теку

Автор snrk7, 14 июн 2022, 20:44

0 Пользователей и 1 гость просматривают эту тему.

snrk7

Подскажите с решением
Предприятие работает ежедневно по графику с 9.00 до 18.00.
При входе пользователя в конфигурацию необходимо проверять соответствует ли текущее
время рабочему. Если нет, то выдавать пользователю сообщение о том, что сейчас заходить в
конфигурацию нельзя и делать безусловный выход из системы. То есть конфигурацию не удастся
запустить в нерабочее время.
Если вход произошел успешно, необходимо запросить у пользователя, какой обед он
предпочитает. Доступно три вида обедов: курица, рыба, мясо. Пользователь может выбирать
сразу несколько вариантов. Для осуществления выбора используйте объект «Список значений».
Результат выбора необходимо хранить в виде глобальной переменной «глОбед», где содержится
массив строк.
При выходе пользователя из системы необходимо проверять закончился ли рабочий день.
Если нет, то задать вопрос о целесообразности покидания системы до окончания рабочего дня. В
зависимости от ответа пользователя необходимо закрывать программу, либо оказываться от этого
действия.

alexandr_ll

snrk7, https://helpf.pro/faq/view/948.html

Как выполнить какую либо процедуру при открытии или закрытии программы?

Распечатать

В Конфигураторе, нажимаем правой кнопкой на конфигурацию:
title
Модуль управляемого приложения
Модуль управляемого приложения является аналогом модуля приложения, но используется для управляемого приложения. 1С:Предприятие 8 исполняется в режиме управляемого приложения, если запущен тонкий клиент, Веб-клиент или толстый клиент и при этом установлен режим управляемого приложения либо на всю конфигурацию, либо у конкретного пользователя. В модуле управляемого приложения могут располагаться объявления переменных, процедуры, функции и тело модуля.
Кроме того, в модуле управляемого приложения могут располагаться предопределенные процедуры ПередНачаломРаботыСистемы, ПриНачалеРаботыСистемы, ПередЗавершениемРаботыСистемы, ПриЗавершенииРаботыСистемы, ОбработкаВнешнегоСобытия. Все процедуры и функции отрабатывают на клиенте. В процедурах и функциях модуля управляемого приложения доступны экспортные процедуры и функции общих модулей управляемого клиента, а также общих неглобальных серверных модулей. Процедуры, функции и переменные модуля управляемого приложения доступны из клиентской части модулей форм и команд.

Добавляем нужный нам код, например:

Код 1C v 8.2 УП Процедура ПриНачалеРаботыСистемы()
Сообщить("Работайте без ошибок ");
КонецПроцедуры

При закытии программы

Код 1C v 8.2 УП Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Работайте без ошибок ");
КонецПроцедуры

Есть еще процедуры Перед:

Код 1C v 8.2 УП Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 8.1 Конфигурация - Модуль приложения
Код 1C v 8.х Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры

Так же есть процедуры Перед:

Код 1C v 8.х Процедура ПередНачаломРаботыСистемы()
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 7.7 Конфигурация - Глобальный модуль
Код 1C v 7.x Процедура ПриНачалеРаботыСистемы()
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры


Теги:  

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск