Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 13:53

подскажите как быть, если фотография добавляется на форму, но не сохраняется

Автор deyray, 07 июн 2022, 19:32

0 Пользователей и 1 гость просматривают эту тему.

deyray

&НаКлиенте
Процедура ДобавитьФото(Команда)
ИмяФайла = "";
ПутьФайла = "";
Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда
ФотоМатериала = ПутьФайла;
УстановитьФото();
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура УстановитьФото()

НовыйФайлФотоМатериала = Справочники.Файлы.СоздатьЭлемент();

НовыйФайлФотоМатериала.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(ФотоМатериала));
ФотоМатериала = ПоместитьВоВременноеХранилище(НовыйФайлФотоМатериала.Файл.Получить());

НовыйФайлФотоМатериала.Записать();

Если Объект.ФотоМатериала.Пустая() = Ложь и Объект.ФотоМатериала.ПолучитьОбъект()<>Неопределено Тогда

СтарыйФайлФотоМатериала = Объект.ФотоМатериала.ПолучитьОбъект();
СтарыйФайлФотоМатериала.Удалить();
КонецЕсли;

Объект.ФотоМатериала = НовыйФайлФотоМатериала.Ссылка;

ЭтаФорма.Модифицированность=Истина;

КонецПроцедуры

&НаКлиенте
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ФотоМатериала = ПолучитьНавигационнуюСсылку(Объект.ФотоМатериала, "Файл");
Элементы.ФотоМатериала.РазмерКартинки = РазмерКартинки.Пропорционально;

КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск