Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2022, 17:25

Автоматическая передача данных в регистр из справочника

Автор mavrinsa, 31 мая 2022, 23:37

0 Пользователей и 1 гость просматривают эту тему.

mavrinsa

Добрый день!
Есть справочник список по, в нем наименование программа и поля страна (разработчика). Есть документ актустановки в котором выбирает из справочника нужное по и указывается ПК на который будет установлено данное по. Как при проведении данного документа заполнить реквизит регистра страна для выбранного в документы по? Заранее спасибо! Реквизиты в регистре нужны для дальнейшей выборки для отчета по определенной стране. Заранее спасибо!

alexandr_ll

mavrinsa, По ссылке на выбраннцю программу "через точку".
Движение.Страна=СтрокаТЧ.Программа.Страна;

mavrinsa

Цитата: alexandr_ll от 01 июн 2022, 06:25mavrinsa, По ссылке на выбраннцю программу "через точку".
Движение.Страна=СтрокаТЧ.Программа.Страна;
Ошибка
{Документ.АктУстановкиПО.МодульОбъекта(18,19)}: Переменная не определена (СтрокаТЧ)
      Движение.Страна=<<?>>СтрокаТЧ.Программа.Страна; (Проверка: Сервер)
Потом понял свою ошибку, ТЧ - это табличная часть! :-)
Вот как все получилось:
Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   // регистр РегУстПОНаМестах Приход
   Движения.РегУстПОНаМестах.Записывать = Истина;
   Для Каждого ТекСтрокаУстановленноПО Из УстановленноПО Цикл
      Движение = Движения.РегУстПОНаМестах.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Программа = ТекСтрокаУстановленноПО.Программа;
      Движение.Страна = ТекСтрокаУстановленноПО.Программа.Страна;
      Движение.РабочееМесто = РабочееМесто;
   КонецЦикла;

   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
Спасибо, Вам огромное!!!!!!!

mavrinsa

Как изменить отображение на форме справочника вместо наименования, например, Фамилия?

mavrinsa

Все разобрался, спасибо!
В конфигураторе заполните поле Синоним для реквизита Наименование как ФИО

mavrinsa

Еще вопросик возник. Справочник сотрудники, в нем фио сотрудника и телефон. Как сделать так чтобы при выборе фио на форме автоматически заполнялся реквизит телефон.
Прописал:
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
ДанныеСотрудника = ПолучитьДанныеСотрудника(ТекСтрокаСотрудник);
Телефон=ДанныеСотрудника .Телефон;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьДанныеСотрудника(Сотрудник)
ДанныеСотрудника = Новый Структура();
ДанныеСотрудника.Вставить("Телефон", Сотрудник.Телефон);
Возврат ДанныеСотрудника;
КонецФункции
Выдает ошибкуБезымянный10.png

alexandr_ll

mavrinsa, Как раз ошибку на вашем скриншоте не видно. Почему вы дублируете сообщения?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск