Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
04 июл 2022, 09:03

Обработчик события "ПриИзменении"

Автор filomonko, 31 мая 2022, 18:05

0 Пользователей и 1 гость просматривают эту тему.

filomonko

Здравствуйте))  :btbzdb:
Возникла проблема.
Есть документ "БронированиеНомеров". При указании даты брони сутки считаются автоматически. Но суммирование со строкой "Сутки" возможно только При изменении этой строки.
Помогите, пожалуйста, сделать так, чтобы происходило суммирование со строкой "Сутки" не только при изменении количества суток. А сразу же после того, как посчитается количество суток, происходило и суммирование))))

&НаКлиенте
Процедура ТЧКоличествоПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные;   
   Стр.Сумма = Стр.Количество * Стр.Цена;   
КонецПроцедуры

&НаКлиенте
Процедура ТЧЦенаПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(Стр);
КонецПроцедуры

&НаКлиенте
Процедура ДатаВыездаПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные; 
   ТЧКоличествоПриИзменении(Элемент);
   Стр.Количество = РасчетДней();
КонецПроцедуры

&НаСервере
Функция РасчетДней()
   
    Количество = 0;

    Если ЗначениеЗаполнено(Объект.ДатаВыезда) и ЗначениеЗаполнено(Объект.ДатаЗаезда) и Объект.ДатаЗаезда < Объект.ДатаВыезда Тогда
         Количество = (Объект.ДатаВыезда - Объект.ДатаЗаезда) / 86400;
    КонецЕсли;   

    Возврат Количество;

КонецФункции

0_0.png

LexaK

filomonko, там же где количество дней/суток посчитали, там же и сумму считайте
добавьте всего одну команду! (возьмите ее из процедуры расчета суммы)
если помогло нажмите: Спасибо!

filomonko

LexaK, из процедуры расчета суммы из общего модуля?

LexaK

filomonko,
"из процедуры расчета суммы из общего модуля?"
-Нет!
из вашей формы, вот же ваш код расчета Суммы
"Стр.Сумма = Стр.Количество * Стр.Цена;"
если помогло нажмите: Спасибо!

filomonko


LexaK

если помогло нажмите: Спасибо!

filomonko


filomonko

LexaK, либо просто не происходит автосуммирование от этого

LexaK

filomonko,
Цитироватьу меня не выходит, добавить команду
так это просто! надо открыть конфигуратор, открыть конструктор документа, открыть форму документа, перейти в модуль формы, и там добавить одну строчку кода
какую: уже писали вам
куда: тоже писали
после этого не забудьте сохранить конфигурацию и применить изменения!
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск