Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 13:28

Отмена проведения документа

Автор filomonko, 25 мая 2022, 17:38

0 Пользователей и 1 гость просматривают эту тему.

filomonko

Здравствуйте!)  :btbzdb:
Нужна помощь))
Есть документ "БронированиеНомеров". Есть документ "ОтменаБронирования".
При проведении документа "БронированиеНомеров" в регистр сведений "СтатусНомера" записывается статус "Забронирован". А при проведении документа "ОтменаБронирования" у номера ставится статус "Свободен".
Необходимо сделать так, чтобы после проведения документа "ОтменаБронирования" у документа "БронированиеНомеров", номер которого уже свободен, отменялось проведение.
Код Модуля объекта "БронированиеНомеров":
Процедура ОбработкаПроведения(Отказ, РежимПроведения)

// регистр СтатусНомера
Движения.СтатусНомера.Записывать = Истина;
Для Каждого ТекСтрокаТЧ Из ТЧ Цикл
Движение = Движения.СтатусНомера.Добавить();
Движение.Период = Дата;
Движение.Номер = ТекСтрокаТЧ.Номер;
Движение.Статус = Перечисления.СтатусНомера.Забронирован;
КонецЦикла;

// регистр РезервНомера
Движения.РезервНомера.Записывать = Истина;
Для Каждого ТекСтрокаТЧ Из ТЧ Цикл
Движение = Движения.РезервНомера.Добавить();
Движение.Номер = ТекСтрокаТЧ.Номер;
Движение.Категория = ТекСтрокаТЧ.Категория;
Движение.Клиент = Клиент;
Движение.ДатаЗаезда = ДатаЗаезда;
Движение.ДатаВыезда = ДатаВыезда;
КонецЦикла;

КонецПроцедуры
Код Модуля объекта "ОтменаБронирования":
Процедура ОбработкаПроведения(Отказ, Режим)

// регистр СтатусНомера
Движения.СтатусНомера.Записывать = Истина;
Движение = Движения.СтатусНомера.Добавить();
Движение.Период = Дата;
Движение.Номер = Комната;
Движение.Статус = Перечисления.СтатусНомера.Свободен;

КонецПроцедуры

ДокБронь.png
ДокОтмена.png
РегСтат.png


alexandr_ll

filomonko, А после отмены бронирования и отмены проведения документа "Бронирование" есть возможность заново провести документ "Бронирование"? Возможно. следует его помечать на удаление?

filomonko

alexandr_ll, думаю, стоит помечать его на удаление

alexandr_ll

filomonko, Дума следует в реквизиты документа "Отмена бронирования" добавить ссылку на документ "Бронирование" и вводить отмену на основании бронирования с заполнением этого реквизита. Тогда обработка документа бронирования будет доступна по ссылке.

filomonko


alexandr_ll

filomonko, Ну вот у вас в Документе "Отмена" видны реквизиты Номер, Дата, Комната. А нужен еще реквизит "Бронирование" с типом Документ.Ссылка. При заполнении документа это поле должно быть заполнено и при проведении этот документ будет доступен по ссылке. https://infostart.ru/1c/articles/333200/

filomonko


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск