Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 13:33

Не запускается регламентное задание по расписанию

Автор кто-то где-то, 20 мая 2022, 14:25

0 Пользователей и 1 гость просматривают эту тему.

кто-то где-то

БП  (3.0.107.34)
Добавил внешнюю обработку, запускаю код через выполнить - все работает
Настроил расписание каждый день; с 0:00:01 по 23:59:59 каждые 30 секунд - само не запускается только вручную
В Регламентные И Фоновые Задания есть обработка если нажать выполнить сейчас - все работает
В журнале регистраций нет ничего по данной обработки

depb

Модуль объекта в обработке проверяли? там должно быть что-то вроде этого

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    ПараметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");

    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Проставить статусы заказов (по расписанию)");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
    ПараметрыРегистрации.Вставить("Информация", НСтр("ru = 'Проставить статусы заказов (по расписанию)'"));
    ПараметрыРегистрации.Вставить("Версия", "1.1.19");
   
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд,
    "Открыть модуль",
    "Модуль",
    "ВызовСерверногоМетода",//"ОткрытиеФормы",//"ОткрытиеФормы",//
    Истина,""
    );   
   
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Истина, Модификатор = "")

    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление = Представление;
    НоваяКоманда.Идентификатор = Идентификатор;
    НоваяКоманда.Использование = Использование;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
    НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры

Функция ВыполнитьКоманду(ИдентификаторКоманды) Экспорт

ВашаПроцедура();

КонецФункции

Теги: БП 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск