Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 июл 2022, 14:20

Обработчик события "ПриИзменении"

Автор filomonko, 19 мая 2022, 18:42

0 Пользователей и 1 гость просматривают эту тему.

filomonko

Здравствуйте))  :btbzdb:
Возникла проблема.
Есть документ "БронированиеНомеров". При указании даты брони сутки считаются автоматически. Но суммирование со строкой "Сутки" возможно только ПриИзменении этой строки.
Помогите, пожалуйста, сделать так, чтобы происходило суммирование со строкой "Сутки" не только при изменении количества суток. А сразу же после того, как посчитается количество суток, происходило и суммирование))))

&НаКлиенте
Процедура ТЧКоличествоПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные;   
   Стр.Сумма = Стр.Количество * Стр.Цена;   
КонецПроцедуры

&НаКлиенте
Процедура ТЧЦенаПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные;
   РаботаСДокументами.РассчитатьСумму(Стр);
КонецПроцедуры

&НаКлиенте
Процедура ДатаВыездаПриИзменении(Элемент)
   Стр = Элементы.ТЧ.ТекущиеДанные; 
   ТЧКоличествоПриИзменении(Элемент);
   Стр.Количество = РасчетДней();
КонецПроцедуры

&НаСервере
Функция РасчетДней()
   
    Количество = 0;

    Если ЗначениеЗаполнено(Объект.ДатаВыезда) и ЗначениеЗаполнено(Объект.ДатаЗаезда) и Объект.ДатаЗаезда < Объект.ДатаВыезда Тогда
         Количество = (Объект.ДатаВыезда - Объект.ДатаЗаезда) / 86400;
    КонецЕсли;   

    Возврат Количество;

КонецФункции

0_0.png

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск