Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 ноя 2022, 13:53

Поиск документа по части номера

Автор кто-то где-то, 19 мая 2022, 10:13

0 Пользователей и 1 гость просматривают эту тему.

кто-то где-то

Всем привет, у меня данные переносятся из УТ в БП и номера встают не правильные, но если удалить номер документа и записать заново, то документ записывается с правильным номером (проблема в префиксах). Щас написал код, который раз в день по нажатию кнопки перезаписывает документ. Но проблема в том, что нужно перебирать не все документы за сутки, а только которые начинаются с префиксом БЁТД-

&НаСервереБезКонтекста
Процедура Команда1НаСервере()
ТекДата = ТекущаяДата();
ТекущаяДата0   = НачалоДня(ТекДата);
ТекущаяДата24    = КонецДня(ТекДата);
Запрос = Новый Запрос;
    Запрос.Текст =  "ВЫБРАТЬ
| ПриходныйКассовыйОрдер.Ссылка КАК Ссылка,
| ПриходныйКассовыйОрдер.Номер КАК Номер,
| ПриходныйКассовыйОрдер.Дата КАК Дата
|ИЗ
| Документ.ПриходныйКассовыйОрдер КАК ПриходныйКассовыйОрдер
|ГДЕ
| ПриходныйКассовыйОрдер.Дата МЕЖДУ &ТекущаяДата0 И &ТекущаяДата24
|
|УПОРЯДОЧИТЬ ПО
| Дата";
    Запрос.УстановитьПараметр("ТекущаяДата0", ТекущаяДата0);
Запрос.УстановитьПараметр("ТекущаяДата24", ТекущаяДата24);

    ТЗ = Запрос.Выполнить().Выгрузить();   
    ДЛя Каждого  Стр Из ТЗ цикл
        ОбъектБД = Стр.ССылка.ПолучитьОбъект();
            //ОбъектБД.ПометкаУдаления = Истина;
ОбъектБД.Номер = "";
            ОбъектБД.Записать();
    КонецЦикла;
 //ОбновитьОтображениеДанных();
//ОбновитьНумерациюОбъектов(Метаданные.Документы.ПриходныйКассовыйОрдер) // Вставить содержимое обработчика.
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

LexaK

кто-то где-то, добавьте такой отбор
|ГДЕ
|   ПриходныйКассовыйОрдер.Дата МЕЖДУ &ТекущаяДата0 И &ТекущаяДата24
|и  ПриходныйКассовыйОрдер.Номер подобно ""БЁТД%""
если помогло нажмите: Спасибо!

Теги: БП 3.0 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск