Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 авг 2022, 20:30

Объеденить данные двух полей реквезитов в одно поле

Автор Defolt, 18 мая 2022, 18:59

0 Пользователей и 1 гость просматривают эту тему.

Defolt

Здравствуйте! У меня в справочнике есть 3 реквезита. Наименование, марка и модель. Мне надо данные реквезитов "марка" и "модель" вывести в реквезит "Наименование".
 Использовал данный код, но выдает ошибку, мол не определенны переменные "модель" и марка".


&НаКлиента
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Наименование = (Модель)+" "+(Марка);         
КонецПроцедуры


На клиенте нельзя как я понял ссылаться на переменные и я преобразовал код вот так:

&НаСервере
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Марка = Справочники.Автомобили.Марка;   
Модель = Справочники.Автомобили.Модель;
Наименование = (Модель)+" "+(Марка);         
КонецПроцедуры

Ошибок не выдает, но и не работает

Тип реквезитов
 
Марка - Ссылка на справочник
Модель - Ссылка на справочник
Наименование - строка

Помогите пожалуйста.

antoneus

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
   Наименование = СтрШаблон("%1 %2", Объект.Модель, Объект.Марка);         
КонецПроцедуры

Но лучше это делать не каждый раз перед записью, а при изменении модели или марки, то есть этот код засунуть в обработчики ПриИзменении реквизитов формы, связанных с этими реквизитами справочника.

LexaK

Хм, тогда уж так, раз используете Объект

   Объект.Наименование = СтрШаблон("%1 %2", Объект.Модель, Объект.Марка);     
если помогло нажмите: Спасибо!

antoneus


Defolt


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск