Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 мая 2022, 21:40

Ввод на основании

Автор Egor97, 11 мая 2022, 13:45

0 Пользователей и 1 гость просматривают эту тему.

ВанСаныч

LexaK, Да, этот код правильный и работает. Сейчас в ДокументСсылка.ЗаказПоставщику в табличную часть Товары добавлена колонка типа булево Объект.Товары.КОформлению истина в ней проставляется командой. Нужно чтобы при вводе на основании заполнялись только строки, в которых флаг проставлен истина. Пытаюсь доработать код и написать проверку перед циклом, никак не получается обратиться КОформлению. Я из за нехватки опыта и знаний не могу понять почему все колонки в этом модуле в доступе кроме новой КОформлению.

LexaK

ВанСаныч, попробуйте примерно такой код
Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаказПоставщику") Тогда
                Склад = ДанныеЗаполнения.Склад;
                Поставщик = ДанныеЗаполнения.Поставщик;
                СуммаДокумента = ДанныеЗаполнения.СуммаДокумента; //а вот сумму надо пересчитать           
            Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл       
Если НоваяСтрока.КОформлению Тогда
            НоваяСтрока = Товары.Добавить();
            НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
            НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
            НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
            НоваяСтрока.ЦенаПоступления = ТекСтрокаТовары.ЦенаПоступления;
КонецЕсли;
        КонецЦикла;   
    КонецЕсли;
ответ Понравился? (в смысле пригодился?)

ВанСаныч

LexaK, Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ЗаказПоставщику") Тогда
Склад = ДанныеЗаполнения.Склад;
Поставщик = ДанныеЗаполнения.Поставщик;
        СуммаДокумента = ДанныеЗаполнения.СуммаДокумента;
Для Каждого ТекСтрокаТовары Из ДанныеЗаполнения.Товары Цикл
Если ТекСтрокаТовары.КОформлению = Истина Тогда
НоваяСтрока = Товары.Добавить();
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.Сумма = ТекСтрокаТовары.Сумма;
НоваяСтрока.ЦенаПоступления = ТекСтрокаТовары.ЦенаПоступления;
   КонецЕсли;
КонецЦикла;
Вот так победил его. Спасибо большое

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск