Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 мая 2022, 08:13

Помогите разобраться

Автор Черника, 20 апр 2022, 14:28

0 Пользователей и 1 гость просматривают эту тему.

Черника

Прошу помочь и не кидаться ни чем.
Задание: Если реквизит счета фактуры = Ложь, счета фактуры бы не создавались
(Обработка выгрузке данных из Аксапта в Бухгалтерию )

1.png

Я правильно понимаю:
1. Добавляю параметр на форме "СчетаФактуры"

ПараметрыПодключения = ФормаОбъект.ПараметрыПодключения;
СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("Организация", Организация);
СтруктураПараметров.Вставить("БезКомиссии", ФормаОбъект.ВыгружатьБезКомиссии);
СтруктураПараметров.Вставить("ЗагружатьНомераСФ", ФормаОбъект.ЗагружатьНомераСчетовФактур);
СтруктураПараметров.Вставить("Склад", ФормаОбъект.Склад);
СтруктураПараметров.Вставить("Доставка", ФормаОбъект.Доставка);
СтруктураПараметров.Вставить("СтатьяДоходовРасходов", ФормаОбъект.СтатьяДоходовРасходов);
СтруктураПараметров.Вставить("ОтражениеВУСН", ФормаОбъект.ОтражениеВУСН);
СтруктураПараметров.Вставить("ДатаЗапретаРедактирования", ПолучитьДатуЗапрета());
СтруктураПараметров.Вставить("СчетаФактуры", ФормаОбъект.ВыгружатьСчетаФактуры);
СтруктураПараметров.Вставить("ПараметрыПодключения", ПараметрыПодключения);
ТаблицаЗагрузки = ОшибкиЗагрузки.Выгрузить();
ОшибкиЗагрузки.Загрузить(ФормаОбъект.ЗагрузкаДокументов(ДокументыАксапта, СтруктураПараметров, ТаблицаЗагрузки));

2. После чего необходимо внести изменения в этот фрагмент
//Создание счетов-фактур
Если НЕ СтрокаТЗ.ФлагОбъединеннойСФ
И НЕ Результат = Документы[СтрокаТЗ.Тип].ПустаяСсылка() Тогда
СчФактура = Документы[СтрокаТЗ.ТипФактуры].СоздатьДокумент();
СчФактура.Заполнить(НовыйДокумент.Ссылка);

Если СтрокаТЗ.ТипФактуры = "СчетФактураПолученный" Тогда
СчФактура.ДатаВходящегоДокумента = СтрокаТЗ.ДатаВход;
СчФактура.НомерВходящегоДокумента = СтрокаТЗ.Фактура;
СчФактура.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыПолученного.НаПоступление;
СчФактура.НДСПредъявленКВычету = Истина;
Если СтрокаТЗ.СпособПолученияСФ = 1 Тогда
СчФактура.КодСпособаПолучения = 2;
КонецЕсли;
КонецЕсли;

Если СтруктураПараметров.ЗагружатьНомераСФ И СтрокаТЗ.ТипФактуры = "СчетФактураВыданный" Тогда
СчФактура.Номер = СтрокаТЗ.Фактура;
СчФактура.ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию;
КонецЕсли;

СчФактура.Ответственный = Пользователи.ТекущийПользователь();

Попытка
СчФактура.Записать();
Исключение
СтрокаТЗОшибок = ТЗОшибок.Добавить();
СтрокаТЗОшибок.Описание = НСтр("ru='Не удалось создать счет-фактуру для документа " + Метаданные.Документы[СтрокаТЗ.Тип].Представление() + " №" + СтрокаТЗ.НомерДок + " от " + СтрокаТЗ.ДатаДок + "'");
КонецПопытки;
КонецЕсли;

КонецЕсли;

Возврат Результат;

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск