Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 мая 2022, 09:27

Автозаполнение поля

Автор Malina23, 18 апр 2022, 14:55

0 Пользователей и 1 гость просматривают эту тему.

Malina23

Добрый день, столкнулся с проблемой того, что автозаполнение поля не хочет работать.
Задача: Автоматически заполнить поле "Наименование" на основе данных полей "Физическое лицо" и "Подразделение". (Физическое лицо и Подразделение - ссылки на другие справочники)
Написанный код:
&НаКлиенте
Процедура ФизическоеЛицоПриИзменении(Элемент)
  СформироватьНаименование();
КонецПроцедуры

&НаКлиенте
Процедура ПодразделениеПриИзменении(Элемент)
  СформироватьНаименование();
КонецПроцедуры

Процедура СформироватьНаименование()
  Объект.Наименование=Объект.ФизическоеЛицо.Наименование +" ("+Объект.Подразделение.Наименование+") ";
КонецПроцедуры

antoneus

Ничего криминального не вижу. Отладчик что говорит?

LexaK

Malina23, вот здесь добавьте

&НаСервере
Процедура СформироватьНаименование()
...
ответ Понравился? (в смысле пригодился?)

Malina23

antoneus, ничего, код как будто не работает совсем

Malina23

LexaK, к сожалению, тот же результат

LexaK

а вы, сами процедуры ПриИзменении... назначили обработчикам событий соответствующим полям?
Поле --> Свойства --> События ...

да, и в вашем случае, название будет меняться только при изменении Физлица или Подразделения

ответ Понравился? (в смысле пригодился?)

Malina23

LexaK, больше вам спасибо, процедуры написать - написал, а назначить из головы вылетело.
Всем спасибо за попытки помочь!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск