Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 окт 2022, 08:09

Загрузка СпискаЗначений в ячейку строки ТЧ

Автор Funt Фунтиков, 13 апр 2022, 11:53

0 Пользователей и 1 гость просматривают эту тему.

Funt Фунтиков

Доброго все времени суток!

Перекопал весь инет, за пол дня так решения и не нашел.
Суть проблемы в следующем:
Есть на обычной форме заполненная ТЧ, из нее собирается СписокЗначений (количество элементов может быть разная).
Так же на форме еще есть одна ТЗ_Отчет в которой автоматически в ячейку колонки ИмяКраски должен загружать этот список, чтобы в каждой из 5 строк данной ячейки можно было выбрать одно из этих значений.

СписокЗначений заполняется вот так:
ВидКраски = Новый СписокЗначений;

Для Каждого СтрокаТЧ Из Материалы Цикл
Если Строка(СтрокаТЧ.ЕдиницаИзмерения) = "кг" Тогда
Сообщить("Наименование " + Строка(СтрокаТЧ.Номенклатура));
ВидКраски.Добавить(Строка(СтрокаТЧ.Номенклатура), Строка(СтрокаТЧ.Номенклатура));
КонецЕсли;
КонецЦикла;

Строки в ТЗ_отчет создаются автоматически:
Для НомСтроки = 1 по 5 Цикл  // заполнение таблицы Первого прогона
НоваяСтрокаТЧ = ОтчетКраска.Добавить();
НоваяСтрокаТЧ.Секция = Строка(НомСтроки);
//НоваяСтрокаТЧ.ИмяКраски = ВидКраски;
//НоваяСтрокаТЧ.ИмяКраски
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск