Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 05:01

Перемещение элемента справочника из одной группы в другую

Автор filomonko, 08 апр 2022, 12:14

0 Пользователей и 1 гость просматривают эту тему.

filomonko

Здравствуйте!))
Очень нужна помощь!))
Необходимо сделать так, чтобы при бронировании номера, когда ставится галочка "Занят", номер из справочника "Номера" перемещался из группы "Свободен" в группу "Занят".
Скрины ниже.
2022-04-07_17-38-11.png
2022-04-07_20-42-54.png

alexandr_ll


filomonko


alexandr_ll

filomonko,
Я уже отвечал на этот вопрос и дал ссылку на пример кода. Что не получается?

filomonko

alexandr_ll, дак там куча примеров. А как для своей задачи сделать непонятно

alexandr_ll

filomonko, В модуле формы должна быть процедура вроде чено-нибудь

&НаКлиенте
Процедура ПриИзмененииЗанят(Команда)

Если Объект.Занят Тогда СменаРодителя(); КонецЕсли;

КонецПроцедуры
&НаСервере
Процедура СменаРодителя()
ТЗ=Объект.ТЧНомера.Выгрузить();
Для Каждого Стр Из ТЗ Цикл
       НомерОбъект=Стр.Номер.ПолучитьОбъект();
       НомерОбект.Родитель=НужныйРодитель;
       НомерОбъект.Записать();
КонецЦикла;
Объект.ТЧНомера.Загрузить(ТЗ);
КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск